summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-10-19 11:38:48 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-10-19 11:39:00 +0200
commit5a4de0cb8a5a2c58023c58167b14996352461dda (patch)
tree46d905abe77725da791561678bb5638cfbf16f6c /dev-java
parentsys-apps/apparmor-utils: add missing dependencies (diff)
downloadgentoo-5a4de0cb8a5a2c58023c58167b14996352461dda.tar.gz
gentoo-5a4de0cb8a5a2c58023c58167b14996352461dda.tar.bz2
gentoo-5a4de0cb8a5a2c58023c58167b14996352461dda.zip
dev-java/hamcrest-core: increased min java version to 1.8
Closes: https://bugs.gentoo.org/749846 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/hamcrest-core/hamcrest-core-1.1-r3.ebuild (renamed from dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild)6
-rw-r--r--dev-java/hamcrest-core/hamcrest-core-1.3-r1.ebuild (renamed from dev-java/hamcrest-core/hamcrest-core-1.3.ebuild)8
2 files changed, 7 insertions, 7 deletions
diff --git a/dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild b/dev-java/hamcrest-core/hamcrest-core-1.1-r3.ebuild
index 78621915ae72..774a1f93f056 100644
--- a/dev-java/hamcrest-core/hamcrest-core-1.1-r1.ebuild
+++ b/dev-java/hamcrest-core/hamcrest-core-1.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,10 +20,10 @@ KEYWORDS="amd64 ~arm ~arm64 ppc64 x86 ~amd64-linux ~x86-macos ~x64-solaris"
IUSE=""
RDEPEND="
- >=virtual/jre-1.6"
+ >=virtual/jre-1.8"
DEPEND="
- >=virtual/jdk-1.6
+ virtual/jdk:1.8
source? ( app-arch/zip )"
S="${WORKDIR}/JavaHamcrest-${MY_PN}-java-${PV}"
diff --git a/dev-java/hamcrest-core/hamcrest-core-1.3.ebuild b/dev-java/hamcrest-core/hamcrest-core-1.3-r1.ebuild
index c57f1153be9d..f6a4828bbca6 100644
--- a/dev-java/hamcrest-core/hamcrest-core-1.3.ebuild
+++ b/dev-java/hamcrest-core/hamcrest-core-1.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -19,11 +19,11 @@ LICENSE="BSD-2"
SLOT="${PV}"
KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~ppc-macos ~x64-macos ~x86-macos"
-DEPEND=">=virtual/jdk-1.5
- ~dev-java/hamcrest-generator-${PV}
+DEPEND="virtual/jdk:1.8
+ ~dev-java/hamcrest-generator-${PV}:1.3
userland_GNU? ( sys-apps/findutils )"
-RDEPEND=">=virtual/jre-1.5"
+RDEPEND=">=virtual/jre-1.8"
JAVA_ANT_REWRITE_CLASSPATH="true"
JAVA_ANT_CLASSPATH_TAGS="${JAVA_ANT_CLASSPATH_TAGS} java java-to-jar"