summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-17 18:24:03 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-17 19:01:27 -0500
commit5c9bd05a5241fe20bcea3b7d72df4cb5b5077c8f (patch)
tree00ff351fa9a02f9a414f6637a4e1b9f286a5b664 /dev-java
parentdev-java/airline: initial ebuild (diff)
downloadgentoo-5c9bd05a5241fe20bcea3b7d72df4cb5b5077c8f.tar.gz
gentoo-5c9bd05a5241fe20bcea3b7d72df4cb5b5077c8f.tar.bz2
gentoo-5c9bd05a5241fe20bcea3b7d72df4cb5b5077c8f.zip
dev-java/jmh-core: initial ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jmh-core/Manifest1
-rw-r--r--dev-java/jmh-core/jmh-core-1.4.1.ebuild39
-rw-r--r--dev-java/jmh-core/metadata.xml8
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/jmh-core/Manifest b/dev-java/jmh-core/Manifest
new file mode 100644
index 000000000000..02e3d2f3dbd9
--- /dev/null
+++ b/dev-java/jmh-core/Manifest
@@ -0,0 +1 @@
+DIST jmh-core-1.4.1.tar.gz 585746 SHA256 1014bbea20eb5a3e5562ddb26c109dccae73cfbbd2b240ed6a40d82f543c42bc SHA512 a33c63b82712deb53218bb8d955c9606e5f393ff0c6256052ac8df022ec45be79bc0ee5ee08ce0d3762594214814bcf1e562717d83daa9ce13c664ca9e7c431b WHIRLPOOL 656ca251087231d7c8b2db99fb8753c9e62c9f5a71c629ba30aba3662bb19131389eaaeef9877790d705eca5bbb7e5074f328fe6eec99f58fb15e3cb34a9d177
diff --git a/dev-java/jmh-core/jmh-core-1.4.1.ebuild b/dev-java/jmh-core/jmh-core-1.4.1.ebuild
new file mode 100644
index 000000000000..cb8ef33e3150
--- /dev/null
+++ b/dev-java/jmh-core/jmh-core-1.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# Hash of tag, download not available via ${PV}
+MY_PN="jmh"
+MY_PV="7ff584954008"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Harness for building, running, and analysing nano/micro/milli/macro benchmarks"
+HOMEPAGE="http://openjdk.java.net/projects/code-tools/jmh"
+SRC_URI="http://hg.openjdk.java.net/code-tools/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# jopt *must* be 4.6, see http://mail.openjdk.java.net/pipermail/jmh-dev/2016-October/002395.html
+CDEPEND="
+ dev-java/asm:4
+ dev-java/commons-math:3
+ =dev-java/jopt-simple-4.6:0
+ dev-java/junit:4
+ source? ( app-arch/zip )
+"
+
+DEPEND=">=virtual/jdk-1.7
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.7
+ ${CDEPEND}"
+
+JAVA_GENTOO_CLASSPATH="asm-4,commons-math-3,jopt-simple,junit-4"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}/${PN}"
diff --git a/dev-java/jmh-core/metadata.xml b/dev-java/jmh-core/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/jmh-core/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>