summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-03-17 12:08:38 +0100
committerSam James <sam@gentoo.org>2022-03-17 21:32:10 +0000
commit7068127d8f8b4a36a38667578e72d0f72688e821 (patch)
tree7575312846f2edf7c71b4f8a974ec8d00f741752 /dev-java
parentnet-misc/ntp: fix IncorrectCopyright (diff)
downloadgentoo-7068127d8f8b4a36a38667578e72d0f72688e821.tar.gz
gentoo-7068127d8f8b4a36a38667578e72d0f72688e821.tar.bz2
gentoo-7068127d8f8b4a36a38667578e72d0f72688e821.zip
dev-java/icedtea-sound: EAPI 8, min java 1.8
Bug: https://bugs.gentoo.org/698580 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/24620 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-sound/icedtea-sound-1.0.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/icedtea-sound/icedtea-sound-1.0.1-r1.ebuild b/dev-java/icedtea-sound/icedtea-sound-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..25e126249722
--- /dev/null
+++ b/dev-java/icedtea-sound/icedtea-sound-1.0.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
+
+EAPI=8
+
+inherit java-pkg-2
+
+DESCRIPTION="Plugins for javax.sound"
+HOMEPAGE="https://icedtea.classpath.org"
+SRC_URI="https://icedtea.classpath.org/download/source/${P}.tar.xz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+IUSE="+doc test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEP="
+ virtual/jdk:1.8
+ >=media-sound/pulseaudio-0.9.11:="
+RDEPEND="${COMMON_DEP}"
+DEPEND="${COMMON_DEP}"
+BDEPEND="app-arch/zip"
+
+pkg_setup() {
+ JAVA_PKG_WANT_SOURCE="1.8"
+ JAVA_PKG_WANT_TARGET="1.8"
+
+ java-pkg-2_pkg_setup
+}
+
+src_configure() {
+ econf --with-jdk-home="${JAVA_HOME}" \
+ $(use_enable doc docs) \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_compile() {
+ default
+}