summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-06-12 00:07:02 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-06-12 23:34:11 +0200
commit71627c5061d1b7f53968b808be6ca87b1d3b1caf (patch)
treef00a6c19628d26ffed1e71eecb2f1b61738c8808 /dev-java
parentdev-java/jansi: EAPI 6 bump. (diff)
downloadgentoo-71627c5061d1b7f53968b808be6ca87b1d3b1caf.tar.gz
gentoo-71627c5061d1b7f53968b808be6ca87b1d3b1caf.tar.bz2
gentoo-71627c5061d1b7f53968b808be6ca87b1d3b1caf.zip
dev-java/jansi: clean up old.
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jansi/jansi-1.5-r1.ebuild32
-rw-r--r--dev-java/jansi/jansi-1.5.ebuild49
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-java/jansi/jansi-1.5-r1.ebuild b/dev-java/jansi/jansi-1.5-r1.ebuild
deleted file mode 100644
index 9b26bc4f300c..000000000000
--- a/dev-java/jansi/jansi-1.5-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-JAVA_PKG_IUSE="source doc"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Java library to output ANSI escape sequences in console"
-HOMEPAGE="http://jansi.fusesource.org/"
-SRC_URI="https://github.com/fusesource/${PN}/archive/${P}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-CDEPEND="dev-java/jansi-native:0"
-
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.6"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.6"
-
-S="${WORKDIR}/${PN}-${P}"
-
-JAVA_GENTOO_CLASSPATH="jansi-native"
-JAVA_SRC_DIR="src"
-
-java_prepare() {
- rm -rf src/test || die
-}
diff --git a/dev-java/jansi/jansi-1.5.ebuild b/dev-java/jansi/jansi-1.5.ebuild
deleted file mode 100644
index 59aef5b8aae7..000000000000
--- a/dev-java/jansi/jansi-1.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-JAVA_PKG_IUSE="source test doc"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="A library that allows you to use ANSI escape sequences in your console output"
-HOMEPAGE="http://jansi.fusesource.org/"
-SRC_URI="https://github.com/fusesource/${PN}/archive/${P}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86"
-
-CDEPEND="dev-java/jansi-native:0"
-
-DEPEND="${CDEPEND}
- test? (
- dev-java/ant-junit4:0
- dev-java/junit:4
- )
- >=virtual/jdk-1.6"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.6"
-
-S="${WORKDIR}/${PN}-${P}"
-
-EANT_GENTOO_CLASSPATH="jansi-native"
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-build.xml build.xml || die
-}
-
-EANT_TEST_GENTOO_CLASSPATH="ant-junit4,junit-4"
-
-src_test() {
- EANT_EXTRA_ARGS="-Djunit.present=true"
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar "target/${P}.jar" "${PN}.jar"
- use source && java-pkg_dosrc src/main/java/org
- use doc && java-pkg_dojavadoc target/site/apidocs
-}