summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-02-02 18:30:03 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-02-03 13:00:09 +0100
commit743111a72f39a1b24f87bd1b2fc32ef707b41407 (patch)
tree87fe0e64960e7b449a79ac7fd371339d1c9a79a6 /dev-java
parentsys-kernel/gentoo-sources: Linuxpatch 4.4.302 (diff)
downloadgentoo-743111a72f39a1b24f87bd1b2fc32ef707b41407.tar.gz
gentoo-743111a72f39a1b24f87bd1b2fc32ef707b41407.tar.bz2
gentoo-743111a72f39a1b24f87bd1b2fc32ef707b41407.zip
dev-java/xerces: Bump to 2.12.2
Closes: https://bugs.gentoo.org/831155 Bug: https://bugs.gentoo.org/831979 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/xerces/Manifest1
-rw-r--r--dev-java/xerces/metadata.xml11
-rw-r--r--dev-java/xerces/xerces-2.12.2.ebuild57
3 files changed, 65 insertions, 4 deletions
diff --git a/dev-java/xerces/Manifest b/dev-java/xerces/Manifest
index e5aebc17815c..aad1076613c2 100644
--- a/dev-java/xerces/Manifest
+++ b/dev-java/xerces/Manifest
@@ -1,2 +1,3 @@
+DIST Xerces-J-src.2.12.2.tar.gz 1812583 BLAKE2B f1b5928abe2852acc4d554c47aa7cbd81a568e15c8a1fd5ea98dc526c52838b0a50920d2ed807e607b01c875676e54578f1493856b06de5a7ba8784591f7f06f SHA512 e71a692212a974ebfa39af5ffd023b433ece34425b12aceeffe89cebe04f28dd8fa46a131a56f30295dca36de115128a6d7e05172c82f5b85d914cd991f34056
DIST xerces-2.12.0.jar 2113705 BLAKE2B 4224b9c00b9c7f388fc40f3bebe6520a21011f36ee1ffcf62e864fe370bbcac8c45b3627d2aff20655f467661a252e1bfd5cb9613f9bbe5b08f1917d09493fa7 SHA512 21f5218f71b3423a883e2bf5c99f7badd5a004a09454d0b218f57f463daf8fe83e7a186b64dd4c19388795a6e6e995f6ed133bbe4c81aab07b0a0d33cf2f7dbb
DIST xerces-2.12.1.jar 2149927 BLAKE2B b02c518754bcab1da9200122b398496c273a84c07a60945c0eea5524a230f5f4815b619685fc41bf48a124f9147803b9452d5d0105b57d535c9c666c52196571 SHA512 2c4ce274904eda6eb4b0b8800dc8383bc6504e215eb9603c45a25c32335651c8ea4d69539b984c048c1974d2aed3d852fff168eb44e2a9b1087ded578394b849
diff --git a/dev-java/xerces/metadata.xml b/dev-java/xerces/metadata.xml
index 6021501589e0..ad8d1c3e6d98 100644
--- a/dev-java/xerces/metadata.xml
+++ b/dev-java/xerces/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>
+ Xerces2 provides high performance, fully compliant XML parsers in the Apache Xerces family. This new version of Xerces continues to build upon the Xerces Native Interface (XNI), a complete framework for building parser components and configurations that is extremely modular and easy to program. The Apache Xerces2 parser is the reference implementation of XNI but other parser components, configurations, and parsers can be written using the Xerces Native Interface. For complete design and implementation documents, refer to the XNI Manual. Xerces2 provides fully conforming XML Schema 1.0 and 1.1 processors. An experimental implementation of the "XML Schema Definition Language (XSD): Component Designators (SCD) Candidate Recommendation (January 2010)" is also provided for evaluation. For more information, refer to the XML Schema page. Xerces2 also provides a complete implementation of the Document Object Model Level 3 Core and Load/Save W3C Recommendations and provides a complete implementation of the XML Inclusions (XInclude) W3C Recommendation. It also provides support for OASIS XML Catalogs v1.1. Xerces2 is able to parse documents written according to the XML 1.1 Recommendation, except that it does not yet provide an option to enable normalization checking as described in section 2.13 of this specification. It also handles namespaces according to the XML Namespaces 1.1 Recommendation, and will correctly serialize XML 1.1 documents if the DOM level 3 load/save APIs are in use.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-java/xerces/xerces-2.12.2.ebuild b/dev-java/xerces/xerces-2.12.2.ebuild
new file mode 100644
index 000000000000..3f22459212e4
--- /dev/null
+++ b/dev-java/xerces/xerces-2.12.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="xerces:xercesImpl:2.12.2"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Xerces Java XML parser"
+HOMEPAGE="https://xerces.apache.org/xerces2-j/index.html"
+SRC_URI="mirror://apache/xerces/j/source/Xerces-J-src.2.12.2.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+CP_DEPEND="
+ dev-java/xml-commons-external:1.4
+ dev-java/xml-commons-resolver:0"
+
+# JDK 11+ already privides the following file and the compilation
+# fails if xerces provides it too. On contrary, compilation on 1.8
+# fails if we don't provide the file because it's not part of 1.8.
+# By restricting compilation to 1.8 and providing the file we build
+# a jar that should work both on 1.8 and also on the newer versions
+# of JDK.
+# the file: "org/w3c/dom/html/HTMLDOMImplementation.class"
+DEPEND="
+ ${CP_DEPEND}
+ virtual/jdk:1.8"
+
+RDEPEND="
+ ${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=( LICENSE NOTICE README {LICENSE.resolver,LICENSE.serializer,NOTICE.resolver,NOTICE.serializer}.txt )
+HTML_DOCS=( {LICENSE.DOM-documentation,LICENSE.DOM-software,LICENSE-SAX,Readme}.html )
+
+S="${WORKDIR}/${P//./_}"
+
+JAVA_SRC_DIR="src"
+JAVA_RESOURCE_DIRS="resources"
+
+src_prepare() {
+ default
+ mkdir "${JAVA_RESOURCE_DIRS}" || die
+ cp -r "${JAVA_SRC_DIR}/org" "${JAVA_RESOURCE_DIRS}" || die
+ find "${JAVA_RESOURCE_DIRS}" -type f -name '*.java' -exec rm -rf {} + || die
+ rm "${JAVA_RESOURCE_DIRS}"/org/apache/xerces/{dom/org.apache.xerces.dom.DOMImplementationSourceImpl,xs/datatypes/package.html,parsers/org*} || die
+}
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}