summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-02-24 13:41:25 +0100
committerJakov Smolić <jsmolic@gentoo.org>2024-02-24 13:41:25 +0100
commit77cd7965e89983c59e4babd6b8dd612f2c0f1648 (patch)
tree22fa9c89d338d5e1175bbe8648703e77766a77f7 /dev-java
parentnet-misc/sysrepo: add 2.2.150 (diff)
downloadgentoo-77cd7965e89983c59e4babd6b8dd612f2c0f1648.tar.gz
gentoo-77cd7965e89983c59e4babd6b8dd612f2c0f1648.tar.bz2
gentoo-77cd7965e89983c59e4babd6b8dd612f2c0f1648.zip
dev-java/osgi-foundation: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/osgi-foundation/Manifest1
-rw-r--r--dev-java/osgi-foundation/files/osgi-foundation-1.2.0-build.xml218
-rw-r--r--dev-java/osgi-foundation/metadata.xml8
-rw-r--r--dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild28
4 files changed, 0 insertions, 255 deletions
diff --git a/dev-java/osgi-foundation/Manifest b/dev-java/osgi-foundation/Manifest
deleted file mode 100644
index cfeb1169a491..000000000000
--- a/dev-java/osgi-foundation/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST osgi-foundation-1.2.0.tar.xz 45176 BLAKE2B 4b5432dfaad9134f402b5f448a8d7ba5f626a7b160bbc953914352a28f745725da851b6c5f2122f820b52f2fd8ad463c2df5c8ae3e2b46ef8bb9d56d89d90f1b SHA512 6523dd6b4cd8205aa3359fae4640ff6b17a1944aec6bf23acf0d6e4eb33839a9b9049e8df0c55a4f35013b40b1df2391a53ed68df682a317c35dca504e9b996b
diff --git a/dev-java/osgi-foundation/files/osgi-foundation-1.2.0-build.xml b/dev-java/osgi-foundation/files/osgi-foundation-1.2.0-build.xml
deleted file mode 100644
index a33f09709ada..000000000000
--- a/dev-java/osgi-foundation/files/osgi-foundation-1.2.0-build.xml
+++ /dev/null
@@ -1,218 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 5/11/13 9:36 AM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="org.osgi.foundation-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="org.osgi.foundation-1.2.0"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.resourceDir.1" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"/>
- <pathelement location="${maven.repo.local}/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.3"
- verbose="false"
- fork="false"
- source="1.3">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.1}">
- <include name="LICENSE*"/>
- <include name="NOTICE*"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases"/>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- <mkdir dir="${maven.repo.local}"/>
- <mkdir dir="${maven.repo.local}/junit/junit/3.8.1"/>
- <get src="http://people.apache.org/repo/m2-snapshot-repository/junit/junit/3.8.1/junit-3.8.1.jar"
- dest="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/junit/junit/3.8.1/junit-3.8.1.jar"
- dest="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <mkdir dir="${maven.repo.local}/easymock/easymock/1.2_Java1.3"/>
- <get src="http://people.apache.org/repo/m2-snapshot-repository/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"
- dest="${maven.repo.local}/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"
- dest="${maven.repo.local}/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- </target>
-
-</project>
diff --git a/dev-java/osgi-foundation/metadata.xml b/dev-java/osgi-foundation/metadata.xml
deleted file mode 100644
index 4221e170cbc0..000000000000
--- a/dev-java/osgi-foundation/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild b/dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild
deleted file mode 100644
index 7adbb2f51fdd..000000000000
--- a/dev-java/osgi-foundation/osgi-foundation-1.2.0-r2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="OSGi R4 Foundation EE by Apache Felix"
-HOMEPAGE="http://felix.apache.org/"
-SRC_URI="https://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz"
-
-LICENSE="Apache-2.0 OSGi-Specification-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-DEPEND=">=virtual/jdk-1.8:*"
-RDEPEND=">=virtual/jre-1.8:*"
-
-src_prepare() {
- default
- cp "${FILESDIR}"/${P}-build.xml "${S}"/build.xml || die
-}
-
-src_install() {
- java-pkg_newjar target/org.osgi.foundation-${PV}.jar org.osgi.foundation.jar
-}