summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-07-24 12:37:07 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-07-24 12:37:28 +0200
commit7f3d44ac56d0f52e9e5d1a810dcd01c55bd5690b (patch)
tree3d118b45f50b7056986234fda1b091436c1d4c35 /dev-java
parentdev-perl/Date-Manip: Bump to version 6.820.0 (diff)
downloadgentoo-7f3d44ac56d0f52e9e5d1a810dcd01c55bd5690b.tar.gz
gentoo-7f3d44ac56d0f52e9e5d1a810dcd01c55bd5690b.tar.bz2
gentoo-7f3d44ac56d0f52e9e5d1a810dcd01c55bd5690b.zip
dev-java/netty-tcnative: bump to 2.0.31
Closes: https://bugs.gentoo.org/733630 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/netty-tcnative/Manifest1
-rw-r--r--dev-java/netty-tcnative/netty-tcnative-2.0.31.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-java/netty-tcnative/Manifest b/dev-java/netty-tcnative/Manifest
index 55d45d9e9fa8..667a99fb65c8 100644
--- a/dev-java/netty-tcnative/Manifest
+++ b/dev-java/netty-tcnative/Manifest
@@ -1 +1,2 @@
DIST netty-tcnative-1.1.33.Fork15.tar.gz 186153 BLAKE2B 3d769a04e659c09aa32059fc2a2eede84f6105469de33ef7d26df436de6a1f6290a6640268934f63f77a969eb6aa024651380cca6dc69099c4016ed61f7d5310 SHA512 592c70a926473a4903b704be920aac1a4fd5a032a8d821a77800b6922b374cb28decf496a65ef62867c027dbac93f0e563e9bb4ecf6659bc70cc33663bb979f5
+DIST netty-tcnative-parent-2.0.31.Final.tar.gz 175283 BLAKE2B 421b8228fb30da7f2983771e3c20e2442ae0c3ef8d12a139a7c01cb43056e916c889294622dbde04443382965750db0195dc667deb34ffcce998ef6381b54eb3 SHA512 0b11d6ec82636e8db09142d345df4b50dbbb7b7a2543f8e4e4d8793205fb22f2f631f454f70b78e93d24a9aeebe55098635c0e9d7a0daf1786b63fe3580aa236
diff --git a/dev-java/netty-tcnative/netty-tcnative-2.0.31.ebuild b/dev-java/netty-tcnative/netty-tcnative-2.0.31.ebuild
new file mode 100644
index 000000000000..da142b72aac4
--- /dev/null
+++ b/dev-java/netty-tcnative/netty-tcnative-2.0.31.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit autotools java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-parent-${PV}.Final"
+MAVEN_ID="io.netty:netty-tcnative:2.0.31"
+
+DESCRIPTION="Fork of Tomcat Native that incorporates various patches"
+HOMEPAGE="https://netty.io/wiki/forked-tomcat-native.html"
+SRC_URI="https://github.com/netty/netty-tcnative/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-libs/apr:1=
+ dev-libs/openssl:0="
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8
+ app-arch/unzip
+ dev-java/maven-hawtjni-plugin:0"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+JAVA_SRC_DIR="${S}/openssl-dynamic/src/main/java"
+NATIVE_DIR="${S}/openssl-dynamic/src/main/native-package"
+
+src_prepare() {
+ default
+
+ cd "${NATIVE_DIR}" || die
+ ln -sn ../c src || die
+ ln -sn . project-template || die
+
+ # Provides missing m4 files and Makefile.am template.
+ unzip -n $(java-pkg_getjars --build-only maven-hawtjni-plugin) project-template/\* || die
+
+ sed -i \
+ -e "s:@PROJECT_NAME@:${PN}:g" \
+ -e "s:@PROJECT_NAME_UNDER_SCORE@:${PN//-/_}:g" \
+ -e "s:@PROJECT_SOURCES@:$(echo src/*.c):g" \
+ Makefile.am || die
+
+ # Avoid dummy version and tedious symlink.
+ sed -i "s/-release @VERSION@/-avoid-version/g" configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ cd "${NATIVE_DIR}" || die
+ econf --with-apr=/usr/bin/apr-1-config --with-ssl=/usr
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ emake -C "${NATIVE_DIR}"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_doso "${NATIVE_DIR}"/.libs/lib${PN}.so
+ dodoc README.md
+}