summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-02 16:55:36 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-04 21:44:02 +0200
commite41e6bb9189f045815f4a9463d0d9a44ec433d83 (patch)
treea186ecc619d974db8ad5d5c6b8348392b0edefe3 /dev-java
parentRevert "net-libs/nodejs: drop 12.22.5-r1, 12.22.6, 12.22.10" (diff)
downloadgentoo-e41e6bb9189f045815f4a9463d0d9a44ec433d83.tar.gz
gentoo-e41e6bb9189f045815f4a9463d0d9a44ec433d83.tar.bz2
gentoo-e41e6bb9189f045815f4a9463d0d9a44ec433d83.zip
dev-java/commons-cli: add 1.5.0
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/25287 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-cli/Manifest1
-rw-r--r--dev-java/commons-cli/commons-cli-1.5.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/commons-cli/Manifest b/dev-java/commons-cli/Manifest
index 5329dda11f02..cb16aa4fe2db 100644
--- a/dev-java/commons-cli/Manifest
+++ b/dev-java/commons-cli/Manifest
@@ -1 +1,2 @@
DIST commons-cli-1.4-src.tar.gz 148530 BLAKE2B 72460ee073b4e8c5179da03c3d599cf04b37b5b3aff89e4927b07765bd879acc9ac56f52e7dee03214e21f7ba9e5af3adf54d2f943aebb266bfa9b4983ba0380 SHA512 a5db856f6154e4340aab1865e3b34c752c0dceb8063faa64740ed470d8e6b3e7782242ae51d6bb57a535a6d6dad2943cc3130d7202223b8f89b8cbecdc3d9d4f
+DIST commons-cli-1.5.0-src.tar.gz 156731 BLAKE2B b3bc3c7426f4564187f6b2fecf2977a8d307277cb244bb51064f32e6d2fc0ddb08c539b3bae68bba5ccc2319d0e483f01f6765ae3e86ebfe99eb775564fd7c8f SHA512 aa2165695177c3e4561f68585cafb5434758138d8a863f3db1860477f660cf78664d2afb07cc3bc767bc8fa87befc7eaa5bdead423ee8b883c62ff00aec7cdda
diff --git a/dev-java/commons-cli/commons-cli-1.5.0.ebuild b/dev-java/commons-cli/commons-cli-1.5.0.ebuild
new file mode 100644
index 000000000000..8fb0198774dc
--- /dev/null
+++ b/dev-java/commons-cli/commons-cli-1.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-cli:commons-cli:1.5.0"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java library for working with the command line arguments and options"
+HOMEPAGE="https://commons.apache.org/proper/commons-cli/"
+SRC_URI="mirror://apache/commons/cli/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DEPEND=">=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+# There were 62 failures:
+# 1) testSimpleLong(org.apache.commons.cli.ParserTestCase)
+# java.lang.InstantiationException
+# at java.base/jdk.internal.reflect.InstantiationExceptionConstructorAccessorImpl.newInstance(InstantiationExceptionConstructorAccessorImpl.java:48)
+# FAILURES!!!
+# Tests run: 444, Failures: 62
+JAVA_TEST_EXCLUDES="org.apache.commons.cli.ParserTestCase"
+
+src_install() {
+ default
+ java-pkg-simple_src_install
+}