summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-05-05 19:44:23 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-05-05 19:44:23 -0400
commit87a8451c49356e280e0bb0acf5afedbd1bdf50ba (patch)
tree25bc3d349c422891b38b97f0aa8f6977ccc237a7 /dev-lang/coffee-script/coffee-script-1.12.5.ebuild
parentdev-vcs/git-imerge: new version 1.0.0. (diff)
downloadgentoo-87a8451c49356e280e0bb0acf5afedbd1bdf50ba.tar.gz
gentoo-87a8451c49356e280e0bb0acf5afedbd1bdf50ba.tar.bz2
gentoo-87a8451c49356e280e0bb0acf5afedbd1bdf50ba.zip
dev-lang/coffee-script: new version 1.12.5.
Gentoo-Bug: 617500 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lang/coffee-script/coffee-script-1.12.5.ebuild')
-rw-r--r--dev-lang/coffee-script/coffee-script-1.12.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-lang/coffee-script/coffee-script-1.12.5.ebuild b/dev-lang/coffee-script/coffee-script-1.12.5.ebuild
new file mode 100644
index 000000000000..e1b9a4e081a3
--- /dev/null
+++ b/dev-lang/coffee-script/coffee-script-1.12.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="coffeescript"
+
+DESCRIPTION="A little language that compiles into javascript"
+HOMEPAGE="http://coffeescript.org/"
+SRC_URI="https://github.com/jashkenas/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# This package has a test suite (that works), but it requires a number
+# of NodeJS/NPM packages that aren't in the tree.
+IUSE="doc examples"
+
+RDEPEND="net-libs/nodejs"
+
+src_install(){
+ local npm_module_dir="/usr/$(get_libdir)/node/${PN}"
+ insinto "${npm_module_dir}"
+ doins *.js package.json
+ doins -r lib
+ dodoc CONTRIBUTING.md README.md
+
+ use doc && dodoc -r documentation
+ use examples && dodoc -r examples
+
+ # The coffee and cake "binaries" use a relative path to find the lib
+ # directory, so we have to symlink them rather than use dobin().
+ exeinto "${npm_module_dir}/bin"
+ doexe bin/cake
+ doexe bin/coffee
+ dosym "${npm_module_dir}/bin/cake" "/usr/bin/cake"
+ dosym "${npm_module_dir}/bin/coffee" "/usr/bin/coffee"
+}