summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-21 22:25:26 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-22 00:53:59 +0100
commit76fc122086248e94e1c1b416f2a0e790b69925ce (patch)
tree4bcbcb9e9284e08af6e07e29ec903c651029cc88 /dev-lang/dafny-bin
parentapp-emacs/load-relative: bump to 1.3.2 (diff)
downloadgentoo-76fc122086248e94e1c1b416f2a0e790b69925ce.tar.gz
gentoo-76fc122086248e94e1c1b416f2a0e790b69925ce.tar.bz2
gentoo-76fc122086248e94e1c1b416f2a0e790b69925ce.zip
dev-lang/dafny-bin: bump to 3.12.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/dafny-bin')
-rw-r--r--dev-lang/dafny-bin/Manifest1
-rw-r--r--dev-lang/dafny-bin/dafny-bin-3.12.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index 71aec7bef6e6..441e6fd1dd8d 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1,2 +1,3 @@
DIST dafny-3.10.0-x64-ubuntu-16.04.zip 76468200 BLAKE2B d3b35260fca709f1808ec47874f5566dd2fc42af9a43354a97b86b8962b1b15c95df10f25fa8f0d6a12c83f5c12569aa981d56b796aeb1fd7563fc59c62d4259 SHA512 3f8e669025fd655a7709334876652176b3dce1eb980f1f797cf829fa53b125129a66a175d3a4fcc56aa276e28661c6d795ccc01901d0e457bdac754b29382ca3
DIST dafny-3.11.0-x64-ubuntu-16.04.zip 76510888 BLAKE2B 03591064f7af8971c5e175b4538c1344d6fd09c4ca2f3c52fef65af424d5fe462112f3853a59a0d3e84bf5945290b3b088472378577cb0881cf8129401606148 SHA512 0535151b0622f70b49457f1eaaa15c031b5ade5e44e64e79a6c6d1c46b9c2fed155f8da72274f8b8dd7815130ce80bd2b7af8a28d9423ebefde80d8cda1d12bb
+DIST dafny-3.12.0-x64-ubuntu-16.04.zip 76588835 BLAKE2B 144928b5e9a32c770d4552be31373defd1153a7ce481aa3948c5fe6c30ff2ce5f20b3d057a587c7762f3c37d63f683275fcf60bbd4ca3754f8713132b3bdfdc9 SHA512 2ea5f97b4fe0f8aaeefd16f739306482824f76ae6c5a37038fedda60bacb2496abc02715c0973a05f845972fd81aeb06e62c3c41d6908c2cf7416006ce8519d4
diff --git a/dev-lang/dafny-bin/dafny-bin-3.12.0.ebuild b/dev-lang/dafny-bin/dafny-bin-3.12.0.ebuild
new file mode 100644
index 000000000000..1d1588371688
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-3.12.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-16.04.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust:0/2.12
+ sci-mathematics/z3
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/dafny
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used
+ # by, for example, compiling/verifying a simple dafny program.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym ../../${dest}/DafnyServer /usr/bin/dafny-server
+}