summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2017-05-24 21:33:04 +0100
committerIan Whyman <thev00d00@gentoo.org>2017-05-24 21:33:04 +0100
commite3b92a8eb71ba2141b960c00558901266a0d7865 (patch)
treece4a7e9bd1b3e4fe9a8d57245b8145508a901c14 /dev-lang/duktape/duktape-2.1.0.ebuild
parentkde-frameworks: Remove KDE Frameworks 5.33.0 (diff)
downloadgentoo-e3b92a8eb71ba2141b960c00558901266a0d7865.tar.gz
gentoo-e3b92a8eb71ba2141b960c00558901266a0d7865.tar.bz2
gentoo-e3b92a8eb71ba2141b960c00558901266a0d7865.zip
dev-lang/duktape: New package, ebuild by me
Thanks to Alexander F Rødseth <xyproto@archlinux.org> for the duktape.pc file. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-lang/duktape/duktape-2.1.0.ebuild')
-rw-r--r--dev-lang/duktape/duktape-2.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/duktape/duktape-2.1.0.ebuild b/dev-lang/duktape/duktape-2.1.0.ebuild
new file mode 100644
index 000000000000..3ec8d5a73f3c
--- /dev/null
+++ b/dev-lang/duktape/duktape-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Embeddable Javascript engine"
+HOMEPAGE="http://duktape.org"
+SRC_URI="http://duktape.org/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+
+ sed -i "s#INSTALL_PREFIX=/usr/local#INSTALL_PREFIX=${D::-1}/usr#" \
+ Makefile.sharedlibrary || die "failed to sed makefile"
+
+ cp "${FILESDIR}/${PN}.pc" "${WORKDIR}" || die
+ sed -i "s#VERSION#${PV}#" "${WORKDIR}/${PN}.pc" || die
+
+ mv Makefile.sharedlibrary Makefile || die "faile to mv makefile"
+}
+
+src_install() {
+ dodir "/usr/lib"
+ dodir "/usr/include"
+ emake install
+}