summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-05-24 15:08:07 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-05-27 09:53:10 +0300
commit32c5d7de3b3f5a3986fe4a33bf184ee5a31c701a (patch)
treef23b65631a6673686de9fc2279c0e90fe181c49d /dev-lang/elixir/elixir-1.13.4.ebuild
parentnet-analyzer/sslsplit: add subslot binder against libevent (diff)
downloadgentoo-32c5d7de3b3f5a3986fe4a33bf184ee5a31c701a.tar.gz
gentoo-32c5d7de3b3f5a3986fe4a33bf184ee5a31c701a.tar.bz2
gentoo-32c5d7de3b3f5a3986fe4a33bf184ee5a31c701a.zip
dev-lang/elixir: add 1.13.4
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/25622 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang/elixir/elixir-1.13.4.ebuild')
-rw-r--r--dev-lang/elixir/elixir-1.13.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/elixir/elixir-1.13.4.ebuild b/dev-lang/elixir/elixir-1.13.4.ebuild
new file mode 100644
index 000000000000..aee01883e02c
--- /dev/null
+++ b/dev-lang/elixir/elixir-1.13.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Elixir programming language"
+HOMEPAGE="https://elixir-lang.org"
+SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 ErlPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-lang/erlang-22:0=[ssl]
+"
+# 'mix' tool collides with sci-biology/phylip, bug #537514
+RDEPEND="${DEPEND}
+ !!sci-biology/phylip
+"
+DEPEND+="
+ test? ( dev-vcs/git )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
+ "${FILESDIR}"/${PN}-1.10.3-no-Q.patch
+ "${FILESDIR}"/${PN}-1.10.3-epmd-daemon.patch
+)
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
+}