summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2019-11-28 11:07:32 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-07 13:46:49 +0000
commitb237bda333a73c1c7f2e1b6041855a58c4c194db (patch)
tree83bc73abee88e12afd2fe05a150e609c2b7f58a6 /dev-lang/erlang
parentmedia-plugins/gst-plugins-ximagesrc: x86 stable wrt bug #702246 (diff)
downloadgentoo-b237bda333a73c1c7f2e1b6041855a58c4c194db.tar.gz
gentoo-b237bda333a73c1c7f2e1b6041855a58c4c194db.tar.bz2
gentoo-b237bda333a73c1c7f2e1b6041855a58c4c194db.zip
dev-lang/erlang: introduce subslots
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/13780 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/erlang-21.1.1.ebuild5
-rw-r--r--dev-lang/erlang/erlang-22.1.1.ebuild5
-rw-r--r--dev-lang/erlang/erlang-22.1.4.ebuild5
-rw-r--r--dev-lang/erlang/erlang-22.1.7.ebuild5
-rw-r--r--dev-lang/erlang/erlang-22.1.8-r1.ebuild5
-rw-r--r--dev-lang/erlang/erlang-22.1.8.ebuild5
6 files changed, 24 insertions, 6 deletions
diff --git a/dev-lang/erlang/erlang-21.1.1.ebuild b/dev-lang/erlang/erlang-21.1.1.ebuild
index d04a12e309c4..45a87c37a08e 100644
--- a/dev-lang/erlang/erlang-21.1.1.ebuild
+++ b/dev-lang/erlang/erlang-21.1.1.ebuild
@@ -18,7 +18,10 @@ SRC_URI="https://github.com/erlang/otp/archive/OTP-${PV}.tar.gz -> ${P}.tar.gz
doc? ( http://erlang.org/download/otp_doc_html_${UPSTREAM_V}.tar.gz -> ${PN}_doc_html_${UPSTREAM_V}.tar.gz )"
LICENSE="Apache-2.0"
-SLOT="0"
+# We use this subslot because Compiled HiPE Code can be loaded on the exact
+# same build of ERTS that was used when compiling the code. See
+# http://erlang.org/doc/system_principles/misc.html for more information.
+SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc emacs +hipe java +kpoll libressl odbc pgo sctp ssl systemd tk wxwidgets"
diff --git a/dev-lang/erlang/erlang-22.1.1.ebuild b/dev-lang/erlang/erlang-22.1.1.ebuild
index 26e520c173d5..8e47b9bf050d 100644
--- a/dev-lang/erlang/erlang-22.1.1.ebuild
+++ b/dev-lang/erlang/erlang-22.1.1.ebuild
@@ -18,7 +18,10 @@ SRC_URI="https://github.com/erlang/otp/archive/OTP-${PV}.tar.gz -> ${P}.tar.gz
doc? ( http://erlang.org/download/otp_doc_html_${UPSTREAM_V}.tar.gz -> ${PN}_doc_html_${UPSTREAM_V}.tar.gz )"
LICENSE="Apache-2.0"
-SLOT="0"
+# We use this subslot because Compiled HiPE Code can be loaded on the exact
+# same build of ERTS that was used when compiling the code. See
+# http://erlang.org/doc/system_principles/misc.html for more information.
+SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc emacs +hipe java +kpoll libressl odbc sctp ssl systemd tk wxwidgets"
diff --git a/dev-lang/erlang/erlang-22.1.4.ebuild b/dev-lang/erlang/erlang-22.1.4.ebuild
index f05b9a30c7e4..cef8524a7f61 100644
--- a/dev-lang/erlang/erlang-22.1.4.ebuild
+++ b/dev-lang/erlang/erlang-22.1.4.ebuild
@@ -18,7 +18,10 @@ SRC_URI="https://github.com/erlang/otp/archive/OTP-${PV}.tar.gz -> ${P}.tar.gz
doc? ( http://erlang.org/download/otp_doc_html_${UPSTREAM_V}.tar.gz -> ${PN}_doc_html_${UPSTREAM_V}.tar.gz )"
LICENSE="Apache-2.0"
-SLOT="0"
+# We use this subslot because Compiled HiPE Code can be loaded on the exact
+# same build of ERTS that was used when compiling the code. See
+# http://erlang.org/doc/system_principles/misc.html for more information.
+SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc emacs +hipe java +kpoll libressl odbc sctp ssl systemd tk wxwidgets"
diff --git a/dev-lang/erlang/erlang-22.1.7.ebuild b/dev-lang/erlang/erlang-22.1.7.ebuild
index edcb9b79b605..36b698f35975 100644
--- a/dev-lang/erlang/erlang-22.1.7.ebuild
+++ b/dev-lang/erlang/erlang-22.1.7.ebuild
@@ -18,7 +18,10 @@ SRC_URI="https://github.com/erlang/otp/archive/OTP-${PV}.tar.gz -> ${P}.tar.gz
doc? ( http://erlang.org/download/otp_doc_html_${UPSTREAM_V}.tar.gz -> ${PN}_doc_html_${UPSTREAM_V}.tar.gz )"
LICENSE="Apache-2.0"
-SLOT="0"
+# We use this subslot because Compiled HiPE Code can be loaded on the exact
+# same build of ERTS that was used when compiling the code. See
+# http://erlang.org/doc/system_principles/misc.html for more information.
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc emacs +hipe java +kpoll libressl odbc sctp ssl systemd tk wxwidgets"
diff --git a/dev-lang/erlang/erlang-22.1.8-r1.ebuild b/dev-lang/erlang/erlang-22.1.8-r1.ebuild
index 744465e2be1b..9f0146d89695 100644
--- a/dev-lang/erlang/erlang-22.1.8-r1.ebuild
+++ b/dev-lang/erlang/erlang-22.1.8-r1.ebuild
@@ -18,7 +18,10 @@ SRC_URI="https://github.com/erlang/otp/archive/OTP-${PV}.tar.gz -> ${P}.tar.gz
doc? ( http://erlang.org/download/otp_doc_html_${UPSTREAM_V}.tar.gz -> ${PN}_doc_html_${UPSTREAM_V}.tar.gz )"
LICENSE="Apache-2.0"
-SLOT="0"
+# We use this subslot because Compiled HiPE Code can be loaded on the exact
+# same build of ERTS that was used when compiling the code. See
+# http://erlang.org/doc/system_principles/misc.html for more information.
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc emacs +hipe java +kpoll libressl odbc sctp ssl systemd tk wxwidgets"
diff --git a/dev-lang/erlang/erlang-22.1.8.ebuild b/dev-lang/erlang/erlang-22.1.8.ebuild
index edcb9b79b605..36b698f35975 100644
--- a/dev-lang/erlang/erlang-22.1.8.ebuild
+++ b/dev-lang/erlang/erlang-22.1.8.ebuild
@@ -18,7 +18,10 @@ SRC_URI="https://github.com/erlang/otp/archive/OTP-${PV}.tar.gz -> ${P}.tar.gz
doc? ( http://erlang.org/download/otp_doc_html_${UPSTREAM_V}.tar.gz -> ${PN}_doc_html_${UPSTREAM_V}.tar.gz )"
LICENSE="Apache-2.0"
-SLOT="0"
+# We use this subslot because Compiled HiPE Code can be loaded on the exact
+# same build of ERTS that was used when compiling the code. See
+# http://erlang.org/doc/system_principles/misc.html for more information.
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc emacs +hipe java +kpoll libressl odbc sctp ssl systemd tk wxwidgets"