summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-11-25 14:14:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-11-25 14:14:24 +0000
commit400835a244982980257478d8d8fc847e401d8731 (patch)
treefebb5dc81b4dcbb5865aa6ca632cd9b683b66712 /dev-lang/ghc/ghc-8.2.2.ebuild
parentdev-lang/scala-bin: Whitespace (diff)
downloadgentoo-400835a244982980257478d8d8fc847e401d8731.tar.gz
gentoo-400835a244982980257478d8d8fc847e401d8731.tar.bz2
gentoo-400835a244982980257478d8d8fc847e401d8731.zip
dev-lang/ghc: add amd64 and x86 binaries
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-lang/ghc/ghc-8.2.2.ebuild')
-rw-r--r--dev-lang/ghc/ghc-8.2.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/ghc/ghc-8.2.2.ebuild b/dev-lang/ghc/ghc-8.2.2.ebuild
index 3113c58efc34..5d07ec194948 100644
--- a/dev-lang/ghc/ghc-8.2.2.ebuild
+++ b/dev-lang/ghc/ghc-8.2.2.ebuild
@@ -26,12 +26,12 @@ arch_binaries=""
#arch_binaries="$arch_binaries alpha? ( http://code.haskell.org/~slyfox/ghc-alpha/ghc-bin-${PV}-alpha.tbz2 )"
#arch_binaries="$arch_binaries arm? ( http://code.haskell.org/~slyfox/ghc-arm/ghc-bin-${PV}-armv7a-hardfloat-linux-gnueabi.tbz2 )"
#arch_binaries="$arch_binaries arm64? ( http://code.haskell.org/~slyfox/ghc-arm64/ghc-bin-${PV}-aarch64-unknown-linux-gnu.tbz2 )"
-#arch_binaries="$arch_binaries amd64? ( http://code.haskell.org/~slyfox/ghc-amd64/ghc-bin-${PV}-x86_64-pc-linux-gnu.tbz2 )"
+arch_binaries="$arch_binaries amd64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-x86_64-pc-linux-gnu.tbz2 )"
#arch_binaries="$arch_binaries ia64? ( http://code.haskell.org/~slyfox/ghc-ia64/ghc-bin-${PV}-ia64-fixed-fiw.tbz2 )"
#arch_binaries="$arch_binaries ppc? ( http://code.haskell.org/~slyfox/ghc-ppc/ghc-bin-${PV}-ppc.tbz2 )"
#arch_binaries="$arch_binaries ppc64? ( http://code.haskell.org/~slyfox/ghc-ppc64/ghc-bin-${PV}-ppc64.tbz2 )"
#arch_binaries="$arch_binaries sparc? ( http://code.haskell.org/~slyfox/ghc-sparc/ghc-bin-${PV}-sparc.tbz2 )"
-#arch_binaries="$arch_binaries x86? ( http://code.haskell.org/~slyfox/ghc-x86/ghc-bin-${PV}-i686-pc-linux-gnu.tbz2 )"
+arch_binaries="$arch_binaries x86? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-i686-pc-linux-gnu.tbz2 )"
# various ports:
#arch_binaries="$arch_binaries x86-fbsd? ( http://code.haskell.org/~slyfox/ghc-x86-fbsd/ghc-bin-${PV}-x86-fbsd.tbz2 )"
@@ -42,12 +42,12 @@ yet_binary() {
#alpha) return 0 ;;
#arm64) return 0 ;;
#arm) return 0 ;;
- #amd64) return 0 ;;
+ amd64) return 0 ;;
#ia64) return 0 ;;
#ppc) return 0 ;;
#ppc64) return 0 ;;
#sparc) return 0 ;;
- #x86) return 0 ;;
+ x86) return 0 ;;
*) return 1 ;;
esac
}