summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-06-09 20:09:03 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-06-09 20:09:17 +0100
commit55e2390cae9029846c6a69d852cf03058b6c4aae (patch)
tree85bcccc359d3fb360fdb7565b17c252685e966b7 /dev-lang/ghc/ghc-8.4.1.ebuild
parentdev-lang/ghc: bump up to 8.4.3, no binaries yet (diff)
downloadgentoo-55e2390cae9029846c6a69d852cf03058b6c4aae.tar.gz
gentoo-55e2390cae9029846c6a69d852cf03058b6c4aae.tar.bz2
gentoo-55e2390cae9029846c6a69d852cf03058b6c4aae.zip
dev-lang/ghc: backport binutils fixes
A few changes: - move off from code.haskell.org to /slyfox.uni.cx for binaries - enable --relax on all arches, not just sparc - fix dwarf generation (-g) on binutils-2.30 - allow >=haskell-updater-1.3 - fix relocation for haddoc, hp2ps, hpc Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-lang/ghc/ghc-8.4.1.ebuild')
-rw-r--r--dev-lang/ghc/ghc-8.4.1.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-lang/ghc/ghc-8.4.1.ebuild b/dev-lang/ghc/ghc-8.4.1.ebuild
index 0e4762bb07d4..e23cc25aadde 100644
--- a/dev-lang/ghc/ghc-8.4.1.ebuild
+++ b/dev-lang/ghc/ghc-8.4.1.ebuild
@@ -23,18 +23,18 @@ HOMEPAGE="http://www.haskell.org/ghc/"
arch_binaries=""
# sorted!
-#arch_binaries="$arch_binaries alpha? ( http://code.haskell.org/~slyfox/ghc-alpha/ghc-bin-${PV}-alpha.tbz2 )"
-#arch_binaries="$arch_binaries arm? ( http://code.haskell.org/~slyfox/ghc-arm/ghc-bin-${PV}-armv7a-hardfloat-linux-gnueabi.tbz2 )"
-#arch_binaries="$arch_binaries arm64? ( http://code.haskell.org/~slyfox/ghc-arm64/ghc-bin-${PV}-aarch64-unknown-linux-gnu.tbz2 )"
+#arch_binaries="$arch_binaries alpha? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-alpha.tbz2 )"
+#arch_binaries="$arch_binaries arm? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-armv7a-hardfloat-linux-gnueabi.tbz2 )"
+#arch_binaries="$arch_binaries arm64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-aarch64-unknown-linux-gnu.tbz2 )"
arch_binaries="$arch_binaries amd64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-x86_64-pc-linux-gnu.tbz2 )"
-#arch_binaries="$arch_binaries ia64? ( http://code.haskell.org/~slyfox/ghc-ia64/ghc-bin-${PV}-ia64-fixed-fiw.tbz2 )"
-#arch_binaries="$arch_binaries ppc? ( http://code.haskell.org/~slyfox/ghc-ppc/ghc-bin-${PV}-ppc.tbz2 )"
-#arch_binaries="$arch_binaries ppc64? ( http://code.haskell.org/~slyfox/ghc-ppc64/ghc-bin-${PV}-ppc64.tbz2 )"
-#arch_binaries="$arch_binaries sparc? ( http://code.haskell.org/~slyfox/ghc-sparc/ghc-bin-${PV}-sparc.tbz2 )"
+#arch_binaries="$arch_binaries ia64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ia64-fixed-fiw.tbz2 )"
+#arch_binaries="$arch_binaries ppc? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ppc.tbz2 )"
+#arch_binaries="$arch_binaries ppc64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ppc64.tbz2 )"
+#arch_binaries="$arch_binaries sparc? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-sparc.tbz2 )"
arch_binaries="$arch_binaries x86? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-i686-pc-linux-gnu.tbz2 )"
# various ports:
-#arch_binaries="$arch_binaries x86-fbsd? ( http://code.haskell.org/~slyfox/ghc-x86-fbsd/ghc-bin-${PV}-x86-fbsd.tbz2 )"
+#arch_binaries="$arch_binaries x86-fbsd? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-x86-fbsd.tbz2 )"
# 0 - yet
yet_binary() {
@@ -473,6 +473,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-7.0.4-CHOST-prefix.patch
eapply "${FILESDIR}"/${PN}-8.2.1-darwin.patch
eapply "${FILESDIR}"/${PN}-7.8.3-prim-lm.patch
+ eapply "${FILESDIR}"/${PN}-8.0.2-no-relax-everywhere.patch
# a bunch of crosscompiler patches
# needs newer version: