summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@users.noreply.github.com>2023-02-09 13:08:05 -0700
committerSam James <sam@gentoo.org>2023-02-21 05:13:28 +0000
commit24cbad0193c8e1e50bc5d30828e88b0872f6620e (patch)
tree5cdafc09c6aed5d7a339e7f5973ddc7e80ad32bb /dev-lang/ghc
parentdev-lang/ghc: Upgrade bundled process package (diff)
downloadgentoo-24cbad0193c8e1e50bc5d30828e88b0872f6620e.tar.gz
gentoo-24cbad0193c8e1e50bc5d30828e88b0872f6620e.tar.bz2
gentoo-24cbad0193c8e1e50bc5d30828e88b0872f6620e.zip
dev-lang/ghc: conditionally apply sphinx patch
The sphinx patch only applies to the source code and will cause a failure if it is applied with USE=binary (this flag disables the unpacking of the source code). This reverts commit 978a89b79928342990c7da40c43a1cc9b84d3e7e. Signed-off-by: hololeap <hololeap@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ghc-9.0.2-r4.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/dev-lang/ghc/ghc-9.0.2-r4.ebuild b/dev-lang/ghc/ghc-9.0.2-r4.ebuild
index 9f6a1b7d14d4..73c3cf5af681 100644
--- a/dev-lang/ghc/ghc-9.0.2-r4.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2-r4.ebuild
@@ -503,9 +503,6 @@ src_prepare() {
[[ -e "${f}" ]] || ln -sf "$($(tc-getPKG_CONFIG) --cflags-only-I libffi | sed "s/-I//g" | tr -d " ")/$(basename "${f}")" "${f}" || die
done
-
- eapply "${FILESDIR}"/${PN}-9.0.2-sphinx-6.patch
-
if use binary; then
if use prefix; then
relocate_ghc "${EPREFIX}"
@@ -592,6 +589,7 @@ src_prepare() {
eapply "${FILESDIR}"/latomic-subword
eapply "${WORKDIR}"/${P}-riscv64-llvm.patch
eapply "${FILESDIR}"/${PN}-9.0.2-fptools.patch # clang-16 workaround
+ eapply "${FILESDIR}"/${PN}-9.0.2-sphinx-6.patch
# mingw32 target
pushd "${S}/libraries/Win32"