summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-05-19 19:33:53 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-05-19 19:33:53 +0200
commitb29590c5ab5e2eabbf8c27a5f4c137979fa0dae7 (patch)
tree0ec4d8e81cd89c6407554fca53a9ddb4ab9d0f7b /dev-lang/gnat-gpl/gnat-gpl-2020.ebuild
parentsys-libs/db: Stabilize 5.3.28-r8 arm, #790803 (diff)
downloadgentoo-b29590c5ab5e2eabbf8c27a5f4c137979fa0dae7.tar.gz
gentoo-b29590c5ab5e2eabbf8c27a5f4c137979fa0dae7.tar.bz2
gentoo-b29590c5ab5e2eabbf8c27a5f4c137979fa0dae7.zip
dev-lang/gnat-gpl: fix VariableScope
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang/gnat-gpl/gnat-gpl-2020.ebuild')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2020.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2020.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2020.ebuild
index 1e59a7091c9f..10317ef96f88 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2020.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2020.ebuild
@@ -52,9 +52,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MYP}
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
-pkg_setup() {
- toolchain_pkg_setup
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ toolchain_src_unpack
+}
+src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
else
@@ -74,23 +83,10 @@ pkg_setup() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
-}
-
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
if use bootstrap; then
- rm ${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
fi
-}
-src_prepare() {
CC=${GCC}
CXX="${gnatbase/gcc/g++}"
GNATBIND="${gnatbase/gcc/gnatbind}"