summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-12-06 19:41:03 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-12-06 19:43:50 -0600
commit3262576e57dc88108b7ce603a2e575c6fdf89e9b (patch)
tree2b8c375496819762fb7fa1006eee9ecfca41d656 /dev-lang/go/go-9999.ebuild
parentx11-base/xorg-server: x86 stable (bug #757882) (diff)
downloadgentoo-3262576e57dc88108b7ce603a2e575c6fdf89e9b.tar.gz
gentoo-3262576e57dc88108b7ce603a2e575c6fdf89e9b.tar.bz2
gentoo-3262576e57dc88108b7ce603a2e575c6fdf89e9b.zip
dev-lang/go: add way to have portage rebuild software written in Go
This adds the @golang-rebuild set to portage to allow rebuilding all known Go software in the tree. This change only affects the live ebuild, but I will be adding it to other versions. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-lang/go/go-9999.ebuild')
-rw-r--r--dev-lang/go/go-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index c81e94e12355..1157708bdb56 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -178,6 +178,10 @@ src_install()
done
einstalldocs
+ # install the @golang-rebuild set for Portage
+ insinto /usr/share/portage/config/sets
+ newins "${FILESDIR}"/go-sets.conf go.conf
+
if [[ ${CHOST} == *-darwin* ]] ; then
# fix install_name for test object (binutils_test) on Darwin, it
# is never used in real circumstances
@@ -189,8 +193,6 @@ src_install()
pkg_postinst() {
[[ -z ${REPLACING_VERSIONS} ]] && return
- has_version "<sys-apps/portage-3.0.9" && return
-
einfo "After ${CATEGORY}/${PN} is updated it is recommended to rebuild"
einfo "all packages compiled with previous versions of ${CATEGORY}/${PN}"
einfo "due to the static linking nature of go."