summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-09-09 18:50:51 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-09-09 18:52:17 -0500
commitfbdb0aab010767690c6bf98906eca4043c2e3567 (patch)
tree99804a41c3034dc8b67641add9bf99cdbaaff5cc /dev-lang/go
parentdev-python/tempita: disable setuptools' 2to3, use epytest (diff)
downloadgentoo-fbdb0aab010767690c6bf98906eca4043c2e3567.tar.gz
gentoo-fbdb0aab010767690c6bf98906eca4043c2e3567.tar.bz2
gentoo-fbdb0aab010767690c6bf98906eca4043c2e3567.zip
dev-lang/go: elevate rebuild instructions to elogs
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-lang/go')
-rw-r--r--dev-lang/go/go-1.17.1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-lang/go/go-1.17.1.ebuild b/dev-lang/go/go-1.17.1.ebuild
index 9fe46e9a8049..65ea8818bf92 100644
--- a/dev-lang/go/go-1.17.1.ebuild
+++ b/dev-lang/go/go-1.17.1.ebuild
@@ -185,13 +185,13 @@ src_install() {
pkg_postinst() {
[[ -z ${REPLACING_VERSIONS} ]] && return
- einfo "After ${CATEGORY}/${PN} is updated it is recommended to rebuild"
- einfo "all packages compiled with previous versions of ${CATEGORY}/${PN}"
- einfo "due to the static linking nature of go."
- einfo "If this is not done, the packages compiled with the older"
- einfo "version of the compiler will not be updated until they are"
- einfo "updated individually, which could mean they will have"
- einfo "vulnerabilities."
- einfo "Run 'emerge @golang-rebuild' to rebuild all 'go' packages"
- einfo "See https://bugs.gentoo.org/752153 for more info"
+ elog "After ${CATEGORY}/${PN} is updated it is recommended to rebuild"
+ elog "all packages compiled with previous versions of ${CATEGORY}/${PN}"
+ elog "due to the static linking nature of go."
+ elog "If this is not done, the packages compiled with the older"
+ elog "version of the compiler will not be updated until they are"
+ elog "updated individually, which could mean they will have"
+ elog "vulnerabilities."
+ elog "Run 'emerge @golang-rebuild' to rebuild all 'go' packages"
+ elog "See https://bugs.gentoo.org/752153 for more info"
}