summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2019-06-20 18:51:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2019-06-20 19:06:08 +0000
commit897c154c167fd539ea827390660c674467ce8635 (patch)
tree6df984d17acd76ae4d95e52b09e8ddb567cbc9c8 /dev-lang/hy/hy-0.16.0.ebuild
parentdev-util/bpftrace: Version bump to 0.9.1_rc (diff)
downloadgentoo-897c154c167fd539ea827390660c674467ce8635.tar.gz
gentoo-897c154c167fd539ea827390660c674467ce8635.tar.bz2
gentoo-897c154c167fd539ea827390660c674467ce8635.zip
dev-lang/hy: Bump
Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-lang/hy/hy-0.16.0.ebuild')
-rw-r--r--dev-lang/hy/hy-0.16.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-lang/hy/hy-0.16.0.ebuild b/dev-lang/hy/hy-0.16.0.ebuild
new file mode 100644
index 000000000000..348c322dc9a5
--- /dev/null
+++ b/dev-lang/hy/hy-0.16.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python{2_7,3_5,3_6})
+
+inherit distutils-r1 eutils
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+RDEPEND=">=dev-python/astor-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/clint-0.4[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/funcparserlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.0-do-not-install-get_version.py.patch )
+
+src_prepare() {
+ default
+ use doc && HTML_DOCS=( docs/_build/html/. )
+}
+
+python_compile_all() {
+ use doc && emake docs
+}
+
+python_test() {
+ nosetests -vv || die "Tests failed under ${EPYTHON}"
+}