summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/icc/icc-13.1.2.146.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/icc/icc-13.1.2.146.ebuild')
-rw-r--r--dev-lang/icc/icc-13.1.2.146.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/icc/icc-13.1.2.146.ebuild b/dev-lang/icc/icc-13.1.2.146.ebuild
new file mode 100644
index 000000000000..0b4bfc936a23
--- /dev/null
+++ b/dev-lang/icc/icc-13.1.2.146.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=2987
+INTEL_DPV=2013_update2
+INTEL_SUBDIR=composerxe
+
+inherit intel-sdp
+
+DESCRIPTION="Intel C/C++ Compiler"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="eclipse"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ eclipse? ( dev-util/eclipse-sdk )"
+RDEPEND="${DEPEND}
+ ~dev-libs/intel-common-${PV}[compiler,multilib=]"
+
+INTEL_BIN_RPMS="compilerproc compilerproc-devel"
+INTEL_DAT_RPMS="compilerproc-common"
+
+CHECKREQS_DISK_BUILD=325M
+
+src_install() {
+ intel-sdp_src_install
+ local i
+ local idir=${INTEL_SDP_EDIR}/compiler/lib
+ for i in ${idir}/{ia32,intel64}/locale/ja_JP/{diagspt,flexnet,helpxi}.cat; do
+ if [[ -e "${i}" ]]; then
+ rm -rvf "${D}${i}" || die
+ fi
+ done
+}