summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-19 19:01:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-19 19:21:03 -0400
commit297d996757be1cf6381bfb06279a896bd9d8ec7d (patch)
tree03d82a229fa5ec18d93e1dc9e6781c1f0b66d18a /dev-lang/ispc
parentdev-lang/ispc: bump to 1.16.0 (diff)
downloadgentoo-297d996757be1cf6381bfb06279a896bd9d8ec7d.tar.gz
gentoo-297d996757be1cf6381bfb06279a896bd9d8ec7d.tar.bz2
gentoo-297d996757be1cf6381bfb06279a896bd9d8ec7d.zip
dev-lang/ispc: minor style fixes, drop cmake gentoo patch
Patch does not make sense anymore given this ebuild is setting another CMAKE_BUILD_TYPE. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ispc-1.16.0.ebuild36
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild36
2 files changed, 32 insertions, 40 deletions
diff --git a/dev-lang/ispc/ispc-1.16.0.ebuild b/dev-lang/ispc/ispc-1.16.0.ebuild
index 8c7854a77667..b0a22ba1f907 100644
--- a/dev-lang/ispc/ispc-1.16.0.ebuild
+++ b/dev-lang/ispc/ispc-1.16.0.ebuild
@@ -5,14 +5,14 @@ EAPI=7
PYTHON_COMPAT=( python3_{8,9,10} )
-inherit cmake python-any-r1 llvm
+inherit cmake llvm python-any-r1
LLVM_MAX_SLOT=12
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="https://ispc.github.io/"
-if [[ ${PV} = *9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ispc/ispc.git"
else
@@ -27,15 +27,12 @@ IUSE="examples"
RDEPEND="<sys-devel/clang-13:="
DEPEND="
${RDEPEND}
- ${PYTHON_DEPS}
- "
+ ${PYTHON_DEPS}"
BDEPEND="
sys-devel/bison
- sys-devel/flex
- "
+ sys-devel/flex"
PATCHES=(
- "${FILESDIR}/${PN}-1.13.0-cmake-gentoo-release.patch"
"${FILESDIR}/${PN}-9999-llvm.patch"
)
@@ -50,7 +47,7 @@ src_prepare() {
# On amd64 systems, build system enables x86/i686 build too.
# This ebuild doesn't even have multilib support, nor need it.
# https://bugs.gentoo.org/730062
- elog "Removing auto-x86 build on amd64"
+ ewarn "Removing auto-x86 build on amd64"
sed -i -e 's:set(target_arch "i686"):return():' cmake/GenerateBuiltins.cmake || die
fi
@@ -59,25 +56,24 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- "-DARM_ENABLED=$(usex arm)"
- "-DCMAKE_SKIP_RPATH=ON"
- "-DISPC_NO_DUMPS=ON"
+ -DARM_ENABLED=$(usex arm)
+ -DCMAKE_SKIP_RPATH=ON
+ -DISPC_NO_DUMPS=ON
)
cmake_src_configure
}
+src_test() {
+ # Inject path to prevent using system ispc
+ PATH="${BUILD_DIR}/bin:${PATH}" ${EPYTHON} ./run_tests.py || die "Testing failed under ${EPYTHON}"
+}
+
src_install() {
dobin "${BUILD_DIR}"/bin/ispc
- dodoc README.md
+ einstalldocs
if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r "${S}"/examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
fi
}
-
-src_test() {
- # Inject path to prevent using system ispc
- PATH="${BUILD_DIR}/bin:${PATH}" ${EPYTHON} ./run_tests.py || die "Testing failed under ${EPYTHON}"
-}
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index 8c7854a77667..b0a22ba1f907 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -5,14 +5,14 @@ EAPI=7
PYTHON_COMPAT=( python3_{8,9,10} )
-inherit cmake python-any-r1 llvm
+inherit cmake llvm python-any-r1
LLVM_MAX_SLOT=12
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="https://ispc.github.io/"
-if [[ ${PV} = *9999 ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ispc/ispc.git"
else
@@ -27,15 +27,12 @@ IUSE="examples"
RDEPEND="<sys-devel/clang-13:="
DEPEND="
${RDEPEND}
- ${PYTHON_DEPS}
- "
+ ${PYTHON_DEPS}"
BDEPEND="
sys-devel/bison
- sys-devel/flex
- "
+ sys-devel/flex"
PATCHES=(
- "${FILESDIR}/${PN}-1.13.0-cmake-gentoo-release.patch"
"${FILESDIR}/${PN}-9999-llvm.patch"
)
@@ -50,7 +47,7 @@ src_prepare() {
# On amd64 systems, build system enables x86/i686 build too.
# This ebuild doesn't even have multilib support, nor need it.
# https://bugs.gentoo.org/730062
- elog "Removing auto-x86 build on amd64"
+ ewarn "Removing auto-x86 build on amd64"
sed -i -e 's:set(target_arch "i686"):return():' cmake/GenerateBuiltins.cmake || die
fi
@@ -59,25 +56,24 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- "-DARM_ENABLED=$(usex arm)"
- "-DCMAKE_SKIP_RPATH=ON"
- "-DISPC_NO_DUMPS=ON"
+ -DARM_ENABLED=$(usex arm)
+ -DCMAKE_SKIP_RPATH=ON
+ -DISPC_NO_DUMPS=ON
)
cmake_src_configure
}
+src_test() {
+ # Inject path to prevent using system ispc
+ PATH="${BUILD_DIR}/bin:${PATH}" ${EPYTHON} ./run_tests.py || die "Testing failed under ${EPYTHON}"
+}
+
src_install() {
dobin "${BUILD_DIR}"/bin/ispc
- dodoc README.md
+ einstalldocs
if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r "${S}"/examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
fi
}
-
-src_test() {
- # Inject path to prevent using system ispc
- PATH="${BUILD_DIR}/bin:${PATH}" ${EPYTHON} ./run_tests.py || die "Testing failed under ${EPYTHON}"
-}