summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-12-21 18:45:16 +0100
committerSam James <sam@gentoo.org>2022-12-24 07:14:25 +0000
commitdc09348059fd08b3857a43953bf559230dad57be (patch)
tree465e546356ddee9d93e395191baa2659ffdc179d /dev-lang/ispc
parentdev-db/mariadb: remove unused patch (diff)
downloadgentoo-dc09348059fd08b3857a43953bf559230dad57be.tar.gz
gentoo-dc09348059fd08b3857a43953bf559230dad57be.tar.bz2
gentoo-dc09348059fd08b3857a43953bf559230dad57be.zip
dev-lang/ispc: remove unused patch
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/28735 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/files/ispc-9999-llvm.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-lang/ispc/files/ispc-9999-llvm.patch b/dev-lang/ispc/files/ispc-9999-llvm.patch
deleted file mode 100644
index 934d9eaf5a60..000000000000
--- a/dev-lang/ispc/files/ispc-9999-llvm.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 13e66268..27ff8364 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -218,10 +218,7 @@ if (WASM_ENABLED)
- list(APPEND ISPC_TARGETS wasm-i32x4)
- endif()
-
--set(CLANG_LIBRARY_LIST clangFrontend clangDriver clangSerialization clangParse clangSema clangAnalysis clangAST clangBasic clangEdit clangLex)
-+set(CLANG_LIBRARY_LIST clang clang-cpp)
--if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "15.0.0")
-- list(APPEND CLANG_LIBRARY_LIST clangSupport)
--endif()
- set(LLVM_COMPONENTS engine ipo bitreader bitwriter instrumentation linker option frontendopenmp)
- if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "15.0.0")
- # windowsdriver is a small library introduced in LLVM 15. While it's targeted at Windows only,
-@@ -402,11 +402,8 @@ if (ISPC_USE_ASAN)
- endif()
-
- # Link against Clang libraries
--foreach(clangLib ${CLANG_LIBRARY_LIST})
-- find_library(${clangLib}Path NAMES ${clangLib} HINTS ${LLVM_LIBRARY_DIRS})
-- list(APPEND CLANG_LIBRARY_FULL_PATH_LIST ${${clangLib}Path})
--endforeach()
--target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_FULL_PATH_LIST})
-+find_package(Clang REQUIRED)
-+target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_LIST})
-
- # Link against LLVM libraries
- target_link_libraries(${PROJECT_NAME} ${LLVM_LIBRARY_LIST} ${CMAKE_DL_LIBS})
-diff --git a/src/llvmutil.cpp b/src/llvmutil.cpp
-index 06fab989..57a7130f 100644
---- a/src/llvmutil.cpp
-+++ b/src/llvmutil.cpp
-@@ -42,6 +42,7 @@
- #include <llvm/IR/BasicBlock.h>
- #include <llvm/IR/Instructions.h>
- #include <llvm/IR/Module.h>
-+#include <llvm/Support/raw_ostream.h>
-
- #ifdef ISPC_GENX_ENABLED
- #include <llvm/GenXIntrinsics/GenXIntrinsics.h>