summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 18:36:37 +0000
committerSam James <sam@gentoo.org>2021-03-16 19:22:28 +0000
commit6c482893713cc649105cbc1f0b787077ab9e1f92 (patch)
tree14a558edaf39ddaa1bce3b507f15305eb9cfe771 /dev-lang/jimtcl
parentapp-text/zathura-pdf-mupdf: drop 0.3.5 (diff)
downloadgentoo-6c482893713cc649105cbc1f0b787077ab9e1f92.tar.gz
gentoo-6c482893713cc649105cbc1f0b787077ab9e1f92.tar.bz2
gentoo-6c482893713cc649105cbc1f0b787077ab9e1f92.zip
dev-lang/jimtcl: drop 0.76
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/jimtcl')
-rw-r--r--dev-lang/jimtcl/Manifest1
-rw-r--r--dev-lang/jimtcl/files/jimtcl-0.75-bootstrap.patch15
-rw-r--r--dev-lang/jimtcl/jimtcl-0.76.ebuild69
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-lang/jimtcl/Manifest b/dev-lang/jimtcl/Manifest
index 37fb80cd1cd4..d26471fa7ada 100644
--- a/dev-lang/jimtcl/Manifest
+++ b/dev-lang/jimtcl/Manifest
@@ -1,2 +1 @@
-DIST jimtcl-0.76.zip 2326715 BLAKE2B 50ea032cf46d2edeeecde1dc3b4deffcbd09b5dd3a6880963608b3f20616bf162fafc4ec2869bfe5de90231c4c9a29fb04710bd299cc5e8728ff20a86e46f32d SHA512 50763ea897fb5393083749cdd9e57a3f3d2d6dbebc40ee6371b1b86ebfc2f515e9775cd2acd6627f0f81b54bd72cd8c74be5aa9d0dbefc7c16372887e07f6ea4
DIST jimtcl-0.78.tar.gz 3073533 BLAKE2B f0cdaf2807c7dd0e7c64e37cbc8dd019d8460e6a0320c239b0d01549aede8c86a89d84d7a3c5200c8d8cea428dbd1038d57dc66f5b580bdea8fe39710f967bbb SHA512 2a2cff12d7fdc4cf36734e41727eef08f6d74fb13d70bb0a3e01839e66859e57dd927ddedc161a6a7928881d640bd4e20a1bb313ed24aa2bb7bcb00eaf64fbf6
diff --git a/dev-lang/jimtcl/files/jimtcl-0.75-bootstrap.patch b/dev-lang/jimtcl/files/jimtcl-0.75-bootstrap.patch
deleted file mode 100644
index 60850e0b6d0b..000000000000
--- a/dev-lang/jimtcl/files/jimtcl-0.75-bootstrap.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-always do a bootstrap w/local jimsh0 to avoid requiring tcl or jimtcl
-to be installed first. the bootstrap prog is small too.
-
---- a/autosetup/find-tclsh
-+++ b/autosetup/find-tclsh
-@@ -4,9 +4,6 @@
- d=`dirname "$0"`
- { "$d/jimsh0" "$d/test-tclsh"; } 2>/dev/null && exit 0
- PATH="$PATH:$d"; export PATH
--for tclsh in jimsh tclsh tclsh8.5 tclsh8.6; do
-- { $tclsh "$d/test-tclsh"; } 2>/dev/null && exit 0
--done
- echo 1>&2 "No installed jimsh or tclsh, building local bootstrap jimsh0"
- for cc in ${CC_FOR_BUILD:-cc} gcc; do
- { $cc -o "$d/jimsh0" "$d/jimsh0.c"; } 2>/dev/null || continue
diff --git a/dev-lang/jimtcl/jimtcl-0.76.ebuild b/dev-lang/jimtcl/jimtcl-0.76.ebuild
deleted file mode 100644
index 64ca59df29e6..000000000000
--- a/dev-lang/jimtcl/jimtcl-0.76.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
- inherit git-r3
-else
- inherit vcs-snapshot
- SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
- KEYWORDS="amd64 arm ~arm64 ~m68k ~mips ~s390 x86"
-fi
-
-DESCRIPTION="Small footprint implementation of Tcl programming language"
-HOMEPAGE="http://jim.tcl.tk/"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="doc static-libs"
-
-RDEPEND=""
-DEPEND="doc? ( app-text/asciidoc )
- app-arch/unzip"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-2_src_unpack
- else
- default
- cd "${WORKDIR}"/msteveb-jimtcl-* || die
- S=${PWD}
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.75-bootstrap.patch
-}
-
-src_configure() {
- CCACHE=None econf --with-jim-shared
- if use static-libs ; then
- # The build does not support doing both simultaneously.
- mkdir static-libs || die
- cd static-libs || die
- CCACHE=None ECONF_SOURCE=${S} econf
- fi
-}
-
-src_compile() {
- # Must build static-libs first.
- use static-libs && emake -C static-libs libjim.a
- emake all
- use doc && emake docs
-}
-
-src_install() {
- dobin jimsh
- use static-libs && dolib.a static-libs/libjim.a
- ln -sf libjim.so.* libjim.so || die
- dolib.so libjim.so*
- insinto /usr/include
- doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h \
- jim-win32compat.h jim-eventloop.h jim-config.h
- dodoc AUTHORS README TODO
- use doc && dohtml Tcl.html
-}