summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-10 11:34:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-10 11:34:47 -0800
commit26013227964c1238b75e40cb2175d5f0c8ad5dc8 (patch)
treeb2e9d68e487f68e6fb6c52fc2a201a5ba609b7fa /dev-lang/jsonnet/jsonnet-0.15.0.ebuild
parentwww-client/firefox: adjust dev-libs/nss dep (diff)
downloadgentoo-26013227964c1238b75e40cb2175d5f0c8ad5dc8.tar.gz
gentoo-26013227964c1238b75e40cb2175d5f0c8ad5dc8.tar.bz2
gentoo-26013227964c1238b75e40cb2175d5f0c8ad5dc8.zip
dev-lang/jsonnet-0.15.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-lang/jsonnet/jsonnet-0.15.0.ebuild')
-rw-r--r--dev-lang/jsonnet/jsonnet-0.15.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.15.0.ebuild b/dev-lang/jsonnet/jsonnet-0.15.0.ebuild
new file mode 100644
index 000000000000..376e4e886d5c
--- /dev/null
+++ b/dev-lang/jsonnet/jsonnet-0.15.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_6 python3_{7,8} )
+
+inherit toolchain-funcs flag-o-matic distutils-r1
+
+DESCRIPTION="A data templating language for app and tool developers "
+HOMEPAGE="https://jsonnet.org/"
+SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="custom-optimization python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+BDEPEND="python? ( ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/jsonnet-0.14.0-makefile.patch"
+ "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+)
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ default
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ use custom-optimization || replace-flags '-O*' -O3
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ jsonnet \
+ libjsonnet.so \
+ libjsonnet++.so
+
+ use python && distutils-r1_src_compile
+}
+
+src_test() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
+ use python && distutils-r1_src_test
+}
+
+src_install() {
+ dolib.so libjsonnet*.so
+ dobin jsonnet
+
+ use python && distutils-r1_src_install
+}