summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-06-30 23:35:31 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-06-30 23:49:06 -0500
commitce5fe500802f8483a322348b4dc3e9c0385842bd (patch)
tree2b19fcf0bb2326df4cc9a5041647d25efd928fff /dev-lang/julia/files
parentdev-lang/julia: fix library installation path (diff)
downloadgentoo-ce5fe500802f8483a322348b4dc3e9c0385842bd.tar.gz
gentoo-ce5fe500802f8483a322348b4dc3e9c0385842bd.tar.bz2
gentoo-ce5fe500802f8483a322348b4dc3e9c0385842bd.zip
dev-lang/julia: drop old version 0.6.2
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-lang/julia/files')
-rw-r--r--dev-lang/julia/files/julia-0.6.0-fix_build_system.patch87
1 files changed, 0 insertions, 87 deletions
diff --git a/dev-lang/julia/files/julia-0.6.0-fix_build_system.patch b/dev-lang/julia/files/julia-0.6.0-fix_build_system.patch
deleted file mode 100644
index 6f8041617751..000000000000
--- a/dev-lang/julia/files/julia-0.6.0-fix_build_system.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-diff --git a/Make.inc b/Make.inc
-index e30c150..e6fdbb2 100644
---- a/Make.inc
-+++ b/Make.inc
-@@ -399,7 +399,7 @@ ifneq ($(OS), WINNT)
- JCXXFLAGS += -pedantic
- endif
- DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -ggdb2 -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECLANG),1)
-@@ -410,7 +410,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS := -fasynchronous-unwind-tables
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g
-+SHIPFLAGS := GENTOOCFLAGS
- ifeq ($(OS), Darwin)
- ifeq ($(USE_LIBCPP), 1)
- MACOSX_VERSION_MIN := 10.8
-@@ -439,7 +439,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS :=
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECCACHE), 1)
-diff --git a/deps/tools/jldownload b/deps/tools/jldownload
-index ab4fd69..e2c2408 100755
---- a/deps/tools/jldownload
-+++ b/deps/tools/jldownload
-@@ -5,9 +5,9 @@
-
- CACHE_HOST=https://cache.julialang.org
-
--WGET=$(which wget 2>/dev/null)
--CURL=$(which curl 2>/dev/null)
--FETCH=$(which fetch 2>/dev/null)
-+WGET=/bin/true
-+CURL=/bin/true
-+FETCH=/bin/true
-
- TIMEOUT=15 # seconds
- WGET_OPTS="--no-check-certificate --tries=1 --timeout=$TIMEOUT"
-diff --git a/doc/Makefile b/doc/Makefile
-index 743804d..e06dde0 100644
---- a/doc/Makefile
-+++ b/doc/Makefile
-@@ -25,7 +25,7 @@ deps: UnicodeData.txt
- $(JLCHECKSUM) UnicodeData.txt
-
- clean:
-- -rm -rf _build/* deps/* docbuild.log UnicodeData.txt
-+ @echo "Do not clean doc/_build/html. Just use it..."
-
- cleanall: clean
-
-diff --git a/src/Makefile b/src/Makefile
-index f71f53d..7cdd23f 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -85,20 +85,8 @@ PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLI
-
- # In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
- # In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
--ifneq ($(USE_LLVM_SHLIB),1)
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --libs $(LLVM_LIBS)) $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --system-libs 2> /dev/null)
--else
--ifeq ($(LLVM_USE_CMAKE),1)
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM
--else
--ifeq ($(OS),WINNT)
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(LLVM_VER_SHORT)
--else
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(shell $(LLVM_CONFIG_HOST) --version)
--endif # OS == WINNT
--endif # LLVM_USE_CMAKE == 1
-+LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
- FLAGS += -DLLVM_SHLIB
--endif # USE_LLVM_SHLIB == 1
-
- COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)
- DEBUG_LIBS := $(WHOLE_ARCHIVE) $(BUILDDIR)/flisp/libflisp-debug.a $(WHOLE_ARCHIVE) $(BUILDDIR)/support/libsupport-debug.a $(COMMON_LIBS)