summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-19 05:27:51 +0000
committerSam James <sam@gentoo.org>2021-11-19 05:27:51 +0000
commit1cd3050cc829569909731b3571b30f05fdc21f30 (patch)
tree68871211415f2027ab2aa1b023e14716054c0b03 /dev-lang/julia
parentkde-apps/kalarmcal: force TZ=UTC for tests (diff)
downloadgentoo-1cd3050cc829569909731b3571b30f05fdc21f30.tar.gz
gentoo-1cd3050cc829569909731b3571b30f05fdc21f30.tar.bz2
gentoo-1cd3050cc829569909731b3571b30f05fdc21f30.zip
dev-lang/julia: fix build with glibc 2.34
Closes: https://bugs.gentoo.org/824486 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/julia')
-rw-r--r--dev-lang/julia/files/julia-1.6.3-glibc-2.34.patch32
-rw-r--r--dev-lang/julia/julia-1.6.3.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-lang/julia/files/julia-1.6.3-glibc-2.34.patch b/dev-lang/julia/files/julia-1.6.3-glibc-2.34.patch
new file mode 100644
index 000000000000..3e3146529aea
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.6.3-glibc-2.34.patch
@@ -0,0 +1,32 @@
+https://github.com/JuliaLang/julia/commit/09a49c6b57fbde109f0f0c2aa9aa05cef2c1dd40
+https://bugs.gentoo.org/824486
+
+From: t-bltg <13423344+t-bltg@users.noreply.github.com>
+Date: Thu, 12 Aug 2021 21:36:18 +0200
+Subject: [PATCH] MINSIGSTKSZ is no longer constant in glibc (#41860)
+
+MINSIGSTKSZ is redefined to sysconf(_SC_MINSIGSTKSZ) starting from glibc 2.34
+
+Co-authored-by: t-bltg <t-bltg@users.noreply.github.com>
+(cherry picked from commit f19b9a20dde2688c642b7dd709b5d9446e4df2f6)
+--- a/src/task.c
++++ b/src/task.c
+@@ -29,6 +29,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <signal.h>
++#include <unistd.h>
+ #include <errno.h>
+ #include <inttypes.h>
+ #include "julia.h"
+@@ -75,8 +76,8 @@ static inline void tsan_switch_to_ctx(jl_ucontext_t *ctx) {}
+
+ // empirically, jl_finish_task needs about 64k stack space to infer/run
+ // and additionally, gc-stack reserves 64k for the guard pages
+-#if defined(MINSIGSTKSZ) && MINSIGSTKSZ > 131072
+-#define MINSTKSZ MINSIGSTKSZ
++#if defined(MINSIGSTKSZ)
++#define MINSTKSZ (MINSIGSTKSZ > 131072 ? MINSIGSTKSZ : 131072)
+ #else
+ #define MINSTKSZ 131072
+ #endif
diff --git a/dev-lang/julia/julia-1.6.3.ebuild b/dev-lang/julia/julia-1.6.3.ebuild
index 83b3fe9df043..096876a7c5a3 100644
--- a/dev-lang/julia/julia-1.6.3.ebuild
+++ b/dev-lang/julia/julia-1.6.3.ebuild
@@ -67,6 +67,7 @@ PATCHES=(
"${FILESDIR}/${PN}"-1.1.0-fix_llvm_install.patch
"${FILESDIR}/${PN}"-1.4.0-no_symlink_llvm.patch
"${FILESDIR}/${PN}"-1.6.0-fix-hardcoded-libs.patch
+ "${FILESDIR}/${PN}"-1.6.3-glibc-2.34.patch
)
pkg_setup() {