summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-13 05:18:44 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-13 06:30:25 +0100
commit7e52b2fa01e313660edcd2f7366045f740c15652 (patch)
tree4b9a95ae45780779748d66b86feecebd86052ad9 /dev-lang/julia
parentapp-crypt/xca: depend on < openssl 3 (diff)
downloadgentoo-7e52b2fa01e313660edcd2f7366045f740c15652.tar.gz
gentoo-7e52b2fa01e313660edcd2f7366045f740c15652.tar.bz2
gentoo-7e52b2fa01e313660edcd2f7366045f740c15652.zip
dev-lang/julia: drop old 1.8.2
Closes: https://bugs.gentoo.org/876184 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/julia')
-rw-r--r--dev-lang/julia/Manifest1
-rw-r--r--dev-lang/julia/julia-1.8.2.ebuild189
-rw-r--r--dev-lang/julia/metadata.xml3
3 files changed, 0 insertions, 193 deletions
diff --git a/dev-lang/julia/Manifest b/dev-lang/julia/Manifest
index 187da4b35048..557e9387b6fd 100644
--- a/dev-lang/julia/Manifest
+++ b/dev-lang/julia/Manifest
@@ -5,5 +5,4 @@ DIST julia-1.8.0-julia-libunwind-1.6.patch 750 BLAKE2B 35bc6a5fef212c1596c88ddff
DIST julia-1.8.0-julia-llvm-14.patch 882 BLAKE2B f46f02554a6fc997763d368b813298da7158c82adbbf43ec98b3d7830163c167d9e1f0e22e17cd42b2900baea91c49611bf5e14a57169beb7f29c505ed161307 SHA512 856e299e7523ae15e6bf579c7aef24d3de67d6e10bfb168f7c5caa887fab1752e321b777d465a3c85947441153c5e898431103272b9f94f28d0fabff77afe7a2
DIST julia-1.8.0-julia-system-cblas.patch 4078 BLAKE2B 58aac552ea63859a03fe24fed69c02f9968aa7924abe2ffdf9e33e965d64877206216f1604f28fc67739cada4b5ce7b508feaad18080e3a5e78d89447d0f2a05 SHA512 d4b437da35672aa0b9f371da66a8675ca5be28276886edafb3566c3ea0d0ed8ed2bac192b43a0d292ee4f2754b596b7b79de76f136cfcada9916ff94a544b372
DIST julia-1.8.0-make-install-no-build.patch 555 BLAKE2B 36a86c3dd281a85f1b1fd68ac9796e70b06bb6afe3140fed97b5c7cd4b24987dc75709c4b1b192d5663c4d704cfb9818ec8d895c293b9b0bd741a3a61c860e47 SHA512 97687d24a3aa0a39994a691026981a91496cd2a82112e9acf9a8edd0f7c2a50d946944e8af495a3b1703f397c7a0e620be76dc28f3bbe14357ee8c4a68a5a3bc
-DIST julia-1.8.2-full.tar.gz 275255487 BLAKE2B dd4cb035c3ec3b37fd08215baa76764c2a447ec50f0afbec5e6c02b047e62188015ba1492704fbc31081465f3837d6b8e02b31cfe10239ddd31e80e4bd7121e8 SHA512 0660911bbd9b0e0df9e6c2af851e7119b6067b08c845422e44101b9a92a1cbc069e52838f503b06f64db5b282cde1b533aafd9c6f47d349ae7d2beb48cf7d7a6
DIST julia-1.8.3-full.tar.gz 275266765 BLAKE2B 2cd54e33cea5d53a93e8ec9c1cd44df4e63a132f2d7a7dca363c6067e1eb5f245a6f65c79bbb29ec641c597ed33fc9376847803b8dd5bc18c537e48d07bcee04 SHA512 0e62d293626c83ff258a3d66aa1e86f9cab114edb8a21ebaad3990332894fbdfd96c23f907debbfd0af9f9f09c0a95a36a3c617784d5eb541b68ed7558630d86
diff --git a/dev-lang/julia/julia-1.8.2.ebuild b/dev-lang/julia/julia-1.8.2.ebuild
deleted file mode 100644
index 3370da1781b4..000000000000
--- a/dev-lang/julia/julia-1.8.2.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic llvm pax-utils toolchain-funcs optfeature
-
-# correct versions for stdlibs are in deps/checksums
-# for everything else, run with network-sandbox and wait for the crash
-
-# 1.8.2 still sits on LLVM 13, bug: https://bugs.gentoo.org/876184
-MY_LLVM_V="13.0.0"
-LLVM_MAX_SLOT=13
-
-DESCRIPTION="High-performance programming language for technical computing"
-HOMEPAGE="https://julialang.org/"
-
-SRC_URI="https://github.com/JuliaLang/julia/releases/download/v${PV}/${P}-full.tar.gz"
-PATCHES=( )
-
-# Huge thanks to Arch Linux developers for the patches.
-# Patches form version 1.8.0 also apply to 1.8.2.
-archlinux_uri="https://raw.githubusercontent.com/archlinux/svntogit-community/packages/julia/trunk/"
-archlinux_patches=(
- 074d761f.patch
- ed9851b0.patch
- julia-hardcoded-libs.patch
- julia-libunwind-1.6.patch
- julia-llvm-14.patch
- julia-system-cblas.patch
- make-install-no-build.patch
-)
-for archlinux_patch in ${archlinux_patches[@]} ; do
- archlinux_patch_name="${PN}-1.8.0-${archlinux_patch}"
- SRC_URI+="
- ${archlinux_uri}/${archlinux_patch} -> ${archlinux_patch_name}
- "
- PATCHES+=( "${DISTDIR}/${archlinux_patch_name}" )
-done
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+system-llvm"
-
-RDEPEND="
- system-llvm? ( sys-devel/llvm:13=[llvm_targets_NVPTX(-)] )
-"
-RDEPEND+="
- app-arch/p7zip
- dev-libs/gmp:0=
- dev-libs/libgit2:0
- >=dev-libs/libpcre2-10.23:0=[jit,unicode]
- dev-libs/mpfr:0=
- >=dev-libs/libutf8proc-2.6.1:0=[-cjk]
- >=dev-util/patchelf-0.13
- >=net-libs/mbedtls-2.2
- net-misc/curl[http2,ssh]
- sci-libs/amd:0=
- sci-libs/arpack:0=
- sci-libs/camd:0=
- sci-libs/ccolamd:0=
- sci-libs/cholmod:0=
- sci-libs/colamd:0=
- sci-libs/fftw:3.0=[threads]
- sci-libs/openlibm:0=
- sci-libs/spqr:0=
- sci-libs/umfpack:0=
- >=sci-mathematics/dsfmt-2.2.4
- >=sys-libs/libunwind-1.1:0=
- sys-libs/zlib:0=
- >=virtual/blas-3.6
- virtual/lapack
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
- !system-llvm? ( dev-util/cmake )
-"
-
-pkg_setup() {
- use system-llvm && llvm_pkg_setup
-}
-
-src_unpack() {
- local tounpack=(${A})
- # the main source tree, followed by deps
- unpack "${tounpack[0]}"
-
- mkdir -p "${S}/deps/srccache/"
- for i in "${tounpack[@]:1}"; do
- cp "${DISTDIR}/${i}" "${S}/deps/srccache/${i#julia-}" || die
- done
-}
-
-src_prepare() {
- default
-
- # Sledgehammer:
- # - prevent fetching of bundled stuff in compile and install phase
- # - respect CFLAGS
- # - respect EPREFIX and Gentoo specific paths
-
- sed -i \
- -e "\|SHIPFLAGS :=|c\\SHIPFLAGS := ${CFLAGS}" \
- Make.inc || die
-
- sed -i \
- -e "s|ar -rcs|$(tc-getAR) -rcs|g" \
- src/Makefile || die
-
- # disable doc install starting git fetching
- sed -i -e 's~install: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html~install: $(build_depsbindir)/stringreplace~' Makefile || die
-}
-
-src_configure() {
- # bug #855602
- filter-lto
-
- use system-llvm && ewarn "You have enabled system-llvm. This is unsupported by upstream and may not work."
-
- # julia does not play well with the system versions of libuv
- # USE_SYSTEM_LIBM=0 implies using external openlibm
- cat <<-EOF > Make.user
- LOCALBASE:="${EPREFIX}/usr"
- override prefix:="${EPREFIX}/usr"
- override libdir:="\$(prefix)/$(get_libdir)"
- override CC:=$(tc-getCC)
- override CXX:=$(tc-getCXX)
- override AR:=$(tc-getAR)
-
- BUNDLE_DEBUG_LIBS:=0
- USE_BINARYBUILDER:=0
- USE_SYSTEM_CSL:=1
- USE_SYSTEM_LLVM:=$(usex system-llvm 1 0)
- USE_SYSTEM_LIBUNWIND:=1
- USE_SYSTEM_PCRE:=1
- USE_SYSTEM_LIBM:=0
- USE_SYSTEM_OPENLIBM:=1
- USE_SYSTEM_DSFMT:=1
- USE_SYSTEM_BLAS:=1
- USE_SYSTEM_LAPACK:=1
- USE_SYSTEM_LIBBLASTRAMPOLINE:=0
- USE_SYSTEM_GMP:=1
- USE_SYSTEM_MPFR:=1
- USE_SYSTEM_LIBSUITESPARSE:=1
- USE_SYSTEM_LIBUV:=0
- USE_SYSTEM_UTF8PROC:=1
- USE_SYSTEM_MBEDTLS:=1
- USE_SYSTEM_LIBSSH2:=1
- USE_SYSTEM_NGHTTP2:=1
- USE_SYSTEM_CURL:=1
- USE_SYSTEM_LIBGIT2:=1
- USE_SYSTEM_PATCHELF:=1
- USE_SYSTEM_ZLIB:=1
- USE_SYSTEM_P7ZIP:=1
- VERBOSE:=1
- EOF
-}
-
-src_compile() {
- # Julia accesses /proc/self/mem on Linux
- addpredict /proc/self/mem
-
- emake -j1
- pax-mark m "$(file usr/bin/julia-* | awk -F : '/ELF/ {print $1}')"
-}
-
-src_install() {
- emake -j1 install DESTDIR="${D}"
- dodoc README.md
-
- if ! use system-llvm ; then
- local llvmslot=$(ver_cut 1 ${MY_LLVM_V})
- cp "${S}/usr/lib/libLLVM-${llvmslot}jl.so" "${ED}/usr/$(get_libdir)/julia/" || die
- fi
-
- mv "${ED}"/usr/etc/julia "${ED}"/etc || die
- rmdir "${ED}"/usr/etc || die
- mv "${ED}"/usr/share/doc/julia/html "${ED}"/usr/share/doc/"${PF}" || die
- rmdir "${ED}"/usr/share/doc/julia || die
-
- # The appdata directory is deprecated.
- mv "${ED}"/usr/share/{appdata,metainfo}/ || die
-}
-
-pkg_postinst() {
- optfeature "Julia Plots" sci-visualization/gr
-}
diff --git a/dev-lang/julia/metadata.xml b/dev-lang/julia/metadata.xml
index b35f6406786f..92529b319549 100644
--- a/dev-lang/julia/metadata.xml
+++ b/dev-lang/julia/metadata.xml
@@ -32,7 +32,4 @@
<upstream>
<remote-id type="github">JuliaLang/julia</remote-id>
</upstream>
- <use>
- <flag name="system-llvm">(Try to) Use the system LLVM install. YMMV.</flag>
- </use>
</pkgmetadata>