summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-15 10:16:37 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-15 10:16:42 +0000
commit74d5d2f5bf743969ddf411ea80737e499d796be9 (patch)
treed0bef64cac3f0026a889d3ea5c39592a8e1d5fd4 /dev-lang/jwasm/jwasm-2.13.ebuild
parentx11-wm/aewm: Install uncompressed man pages (diff)
downloadgentoo-74d5d2f5bf743969ddf411ea80737e499d796be9.tar.gz
gentoo-74d5d2f5bf743969ddf411ea80737e499d796be9.tar.bz2
gentoo-74d5d2f5bf743969ddf411ea80737e499d796be9.zip
dev-lang/jwasm: bump up to 2.13
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/jwasm/jwasm-2.13.ebuild')
-rw-r--r--dev-lang/jwasm/jwasm-2.13.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-lang/jwasm/jwasm-2.13.ebuild b/dev-lang/jwasm/jwasm-2.13.ebuild
new file mode 100644
index 000000000000..6216a512fe90
--- /dev/null
+++ b/dev-lang/jwasm/jwasm-2.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MASM-compatible TASM-similar assembler (fork of Wasm)"
+HOMEPAGE="https://github.com/JWasm/JWasm"
+SRC_URI="https://github.com/JWasm/JWasm/archive/${PV}.tar.gz"
+LICENSE="Watcom-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/JWasm-${PV}"
+
+PATCHES=("${FILESDIR}"/${PN}-2.11-types-test.patch)
+
+src_prepare() {
+ default
+
+ # don't strip binary
+ sed -i GccUnix.mak -e 's/ -s / /g' || die
+}
+
+src_compile() {
+ emake -f GccUnix.mak CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin GccUnixR/jwasm
+ dodoc *.txt Doc/*.txt
+}