summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-25 15:16:31 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-25 15:16:54 +0200
commit5b536f3db01947f3b766081bfa805f8590a6ecfc (patch)
tree5eab0205ad6761d92c531eeec681b425973c9c46 /dev-lang/lfe/lfe-1.1.1.ebuild
parentmedia-video/mpv: remove old (diff)
downloadgentoo-5b536f3db01947f3b766081bfa805f8590a6ecfc.tar.gz
gentoo-5b536f3db01947f3b766081bfa805f8590a6ecfc.tar.bz2
gentoo-5b536f3db01947f3b766081bfa805f8590a6ecfc.zip
dev-lang/lfe: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-lang/lfe/lfe-1.1.1.ebuild')
-rw-r--r--dev-lang/lfe/lfe-1.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/lfe/lfe-1.1.1.ebuild b/dev-lang/lfe/lfe-1.1.1.ebuild
new file mode 100644
index 000000000000..463323b172ab
--- /dev/null
+++ b/dev-lang/lfe/lfe-1.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Lisp-flavoured Erlang"
+HOMEPAGE="http://lfe.github.io/"
+SRC_URI="https://github.com/rvirding/lfe/archive/v${PV}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ export PATH="${S}/bin:$PATH"
+}
+
+src_compile() {
+ emake compile -j1
+}
+
+src_install() {
+ dobin bin/lfe
+ dobin bin/lfec
+ dobin bin/lfescript
+ dodir /usr/$(get_libdir)/erlang/lib/lfe/ebin/
+ dodir /usr/$(get_libdir)/erlang/lib/lfe/emacs/
+ cp -R "${S}/ebin" "${D}/usr/$(get_libdir)/erlang/lib/lfe/"
+ cp -R "${S}/emacs" "${D}/usr/$(get_libdir)/erlang/lib/lfe/"
+}