summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-07 23:47:06 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-08 00:39:04 +0200
commite0fbefccc05db31daa50acd3c09bc823e7bf6e00 (patch)
treed31c141fd777224922efc8f6b3df9a5438ecb65f /dev-lang/mond
parentdev-dotnet/coco: use RollForward to update to .NET 7.0 (diff)
downloadgentoo-e0fbefccc05db31daa50acd3c09bc823e7bf6e00.tar.gz
gentoo-e0fbefccc05db31daa50acd3c09bc823e7bf6e00.tar.bz2
gentoo-e0fbefccc05db31daa50acd3c09bc823e7bf6e00.zip
dev-lang/mond: use RollForward to update to .NET 7.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/mond')
-rw-r--r--dev-lang/mond/mond-0.9.4-r1.ebuild (renamed from dev-lang/mond/mond-0.9.4.ebuild)9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-lang/mond/mond-0.9.4.ebuild b/dev-lang/mond/mond-0.9.4-r1.ebuild
index 99a0a2af7a4f..1b9f50069855 100644
--- a/dev-lang/mond/mond-0.9.4.ebuild
+++ b/dev-lang/mond/mond-0.9.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DOTNET_PKG_COMPAT=6.0
+DOTNET_PKG_COMPAT=7.0
NUGETS="
fleck@1.2.0
microsoft.build.tasks.git@1.1.1
@@ -102,6 +102,7 @@ SRC_URI+=" ${NUGET_URIS} "
LICENSE="MIT"
SLOT="0"
+DOTNET_PKG_BUILD_EXTRA_ARGS=( -p:RollForward=Major )
DOTNET_PKG_PROJECTS=( Mond.Repl/Mond.Repl.csproj )
DOCS=( README.md Examples )
@@ -109,11 +110,15 @@ DOCS=( README.md Examples )
src_unpack() {
dotnet-pkg_src_unpack
- if [[ -n ${EGIT_REPO_URI} ]] ; then
+ if [[ -n "${EGIT_REPO_URI}" ]] ; then
git-r3_src_unpack
fi
}
+src_test() {
+ dotnet-pkg-base_test -p:RollForward=Major Mond.sln
+}
+
src_install() {
dotnet-pkg-base_install
dotnet-pkg-base_dolauncher "/usr/share/${P}/Mond.Repl" "${PN}"