summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 22:34:12 +0100
committerSam James <sam@gentoo.org>2021-04-18 06:55:04 +0100
commit5a03cbb36bfe3cfa5e27e675ab61891b5671180f (patch)
tree2d92f6fd747e35488344ba690decd6ccd2313e57 /dev-lang/pcc
parentdev-lang/pcc: eutils-- (diff)
downloadgentoo-5a03cbb36bfe3cfa5e27e675ab61891b5671180f.tar.gz
gentoo-5a03cbb36bfe3cfa5e27e675ab61891b5671180f.tar.bz2
gentoo-5a03cbb36bfe3cfa5e27e675ab61891b5671180f.zip
dev-lang/pcc: versionator--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/pcc')
-rw-r--r--dev-lang/pcc/pcc-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-lang/pcc/pcc-9999.ebuild b/dev-lang/pcc/pcc-9999.ebuild
index 3b593d6ba172..a507114c0400 100644
--- a/dev-lang/pcc/pcc-9999.ebuild
+++ b/dev-lang/pcc/pcc-9999.ebuild
@@ -3,15 +3,16 @@
EAPI=5
-inherit versionator autotools
+inherit autotools
DESCRIPTION="pcc portable c compiler"
HOMEPAGE="http://pcc.ludd.ltu.se"
-if [[ ${PV} = 9999 ]]; then
- inherit cvs
+if [[ ${PV} == 9999 ]]; then
ECVS_SERVER="pcc.ludd.ltu.se:/cvsroot"
ECVS_MODULE="${PN}"
+ inherit cvs
+
S="${WORKDIR}/${PN}"
else
SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
@@ -20,7 +21,7 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE=""
+
DEPEND=">=dev-libs/pcc-libs-${PV}"
RDEPEND="${DEPEND}"
@@ -34,10 +35,6 @@ src_configure() {
econf --disable-stripping
}
-src_compile() {
- emake
-}
-
src_install() {
emake DESTDIR="${D}" install
}