summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-21 12:07:32 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-22 03:04:54 +1200
commit38a9278233b784c5115e344b9b3d8263d5268f2e (patch)
tree583a8d3c58338325640b06162d7a9c7fac4dc231 /dev-lang/perl/perl-5.26.9999.ebuild
parentapp-crypt/debian-archive-keyring: Save compiling non-code (bug #614932) (diff)
downloadgentoo-38a9278233b784c5115e344b9b3d8263d5268f2e.tar.gz
gentoo-38a9278233b784c5115e344b9b3d8263d5268f2e.tar.bz2
gentoo-38a9278233b784c5115e344b9b3d8263d5268f2e.zip
dev-lang/perl: Make new OLDVERSEN strategy for NEXTVER
As per discussion on #gentoo-perl, this is slated as a strategy for 5.26, as it means people who upgrade to 5.26 retain existing installed modules in their @INC This serves as additional defence against portage build-order issues, which are going to become especially pertinent given we're going to have a substantial number of packages likely to fail configure or test. So its important that people who can't rebuild packages can still have existing versions continue to work on the newer perl where possible. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-lang/perl/perl-5.26.9999.ebuild')
-rw-r--r--dev-lang/perl/perl-5.26.9999.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-lang/perl/perl-5.26.9999.ebuild b/dev-lang/perl/perl-5.26.9999.ebuild
index 8a3df3918ab8..c2fddc553e74 100644
--- a/dev-lang/perl/perl-5.26.9999.ebuild
+++ b/dev-lang/perl/perl-5.26.9999.ebuild
@@ -10,13 +10,12 @@ CROSS_VER=1.1.4
DIST_AUTHOR=XSAWYERX
-# NB: BIN_ are perls that are XS-Compatible
+# Greatest first, don't include yourself
+# Devel point-releases are not ABI-intercompatible, but stable point releases are
+# BIN_OLDVERSEN is contains only C-ABI-intercompatible versions
+PERL_BIN_OLDVERSEN=""
+PERL_OLDVERSEN="5.25.12 5.25.11 5.24.2 5.24.1 5.24.0 5.22.3 5.22.2 5.22.1 5.22.0"
if [[ "${PV##*.}" == "9999" ]]; then
- # Include more versions for blead releases
- # for circular reasons
- # Greatest first, don't include yourself
- PERL_BIN_OLDVERSEN=""
- PERL_OLDVERSEN="5.25.12 5.25.11 5.24.2 5.24.1 5.24.0 5.22.3 5.22.2 5.22.1 5.22.0"
DIST_VERSION=5.26.0-RC1
SHORT_PV="${DIST_VERSION%.*}"
# Devel Releases are not ABI-intercompatible
@@ -25,9 +24,6 @@ if [[ "${PV##*.}" == "9999" ]]; then
PATCH_BASE="perl-5.25.11-patches-${PATCH_VER}"
MY_PV="${DIST_VERSION%_rc*}"
else
- PERL_BIN_OLDVERSEN=""
- # Compat reasons
- PERL_OLDVERSEN="5.25.12 5.25.11"
# First 2 digits only
SHORT_PV="${PV%.*}"
SUBSLOT="${SHORT_PV}"