summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-12-26 13:44:38 +0100
committerFabian Groffen <grobian@gentoo.org>2020-12-26 13:45:44 +0100
commit564d68aa779719c613994f6b933cbb3f31e00d3a (patch)
tree123b8e1a9ad5b053b1187afa7e80041976d94e4f /dev-lang/perl/perl-5.32.0-r1.ebuild
parentdev-lang/tcl: fix installation of README (diff)
downloadgentoo-564d68aa779719c613994f6b933cbb3f31e00d3a.tar.gz
gentoo-564d68aa779719c613994f6b933cbb3f31e00d3a.tar.bz2
gentoo-564d68aa779719c613994f6b933cbb3f31e00d3a.zip
dev-lang/perl: fix flock on sparc-solaris
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-lang/perl/perl-5.32.0-r1.ebuild')
-rw-r--r--dev-lang/perl/perl-5.32.0-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-lang/perl/perl-5.32.0-r1.ebuild b/dev-lang/perl/perl-5.32.0-r1.ebuild
index 0c5fdc0e83d1..0791da1fc3b8 100644
--- a/dev-lang/perl/perl-5.32.0-r1.ebuild
+++ b/dev-lang/perl/perl-5.32.0-r1.ebuild
@@ -622,6 +622,10 @@ src_configure() {
[[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] && tc-is-gcc && \
append-cflags -Dinline=__inline__
+ # flock on 32-bit sparc Solaris is broken, fall back to fcntl
+ [[ ${CHOST} == sparc-*-solaris* ]] && \
+ myconf -Ud_flock
+
# Prefix: the host system needs not to follow Gentoo multilib stuff, and in
# Prefix itself we don't do multilib either, so make sure perl can find
# something compatible.
@@ -629,7 +633,7 @@ src_configure() {
# Set a hook to check for each detected library whether it actually works.
export libscheck="
( echo 'main(){}' > '${T}'/conftest.c &&
- $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
+ $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
) || xxx=/dev/null"
# Use all host paths that might contain useful stuff, the hook above will filter out bad choices.