summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-06-26 16:21:27 -0400
committerBrian Evans <grknight@gentoo.org>2018-06-26 16:21:27 -0400
commit515e521c643a8d92c25a8a1e66c9c200a1f4f3c0 (patch)
treef7525c0d69138164278876b8d63c9f6fa044e582 /dev-lang/php/php-7.1.18.ebuild
parentnet-wireless/chirp: bump, cleanup (diff)
downloadgentoo-515e521c643a8d92c25a8a1e66c9c200a1f4f3c0.tar.gz
gentoo-515e521c643a8d92c25a8a1e66c9c200a1f4f3c0.tar.bz2
gentoo-515e521c643a8d92c25a8a1e66c9c200a1f4f3c0.zip
dev-lang/php: Silence uncontrolable repoman warnings
The addpredicts originate due to libsnmp that PHP cannot change in its behaviour Silence the warnings to find real problems Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-lang/php/php-7.1.18.ebuild')
-rw-r--r--dev-lang/php/php-7.1.18.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/php/php-7.1.18.ebuild b/dev-lang/php/php-7.1.18.ebuild
index d2e931661bb5..29a9d115dfdb 100644
--- a/dev-lang/php/php-7.1.18.ebuild
+++ b/dev-lang/php/php-7.1.18.ebuild
@@ -224,8 +224,8 @@ src_prepare() {
}
src_configure() {
- addpredict /usr/share/snmp/mibs/.index
- addpredict /var/lib/net-snmp/mib_indexes
+ addpredict /usr/share/snmp/mibs/.index #nowarn
+ addpredict /var/lib/net-snmp/mib_indexes #nowarn
PHP_DESTDIR="${EPREFIX}/usr/$(get_libdir)/php${SLOT}"
@@ -478,8 +478,8 @@ src_configure() {
src_compile() {
# snmp seems to run during src_compile, too (bug #324739)
- addpredict /usr/share/snmp/mibs/.index
- addpredict /var/lib/net-snmp/mib_indexes
+ addpredict /usr/share/snmp/mibs/.index #nowarn
+ addpredict /var/lib/net-snmp/mib_indexes #nowarn
for sapi in ${SAPIS} ; do
if use "${sapi}"; then
@@ -492,7 +492,7 @@ src_compile() {
src_install() {
# see bug #324739 for what happens when we don't have that
- addpredict /usr/share/snmp/mibs/.index
+ addpredict /usr/share/snmp/mibs/.index #nowarn
# grab the first SAPI that got built and install common files from there
local first_sapi=""