summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-03 21:47:25 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-03 21:48:16 +0100
commitac8830e5ca56ab4ba2a047220e5462024b32444d (patch)
treed81859baf2e8a91919fd72b18de224f4706b384d /dev-lang/php/php-7.4.13.ebuild
parentsci-chemistry/gromacs: Version bump (diff)
downloadgentoo-ac8830e5ca56ab4ba2a047220e5462024b32444d.tar.gz
gentoo-ac8830e5ca56ab4ba2a047220e5462024b32444d.tar.bz2
gentoo-ac8830e5ca56ab4ba2a047220e5462024b32444d.zip
dev-lang/php: fix building against libressl
Fixes ext/openssl/openssl.c:6501:8: error: ‘EVP_CIPH_OCB_MODE’ undeclared (first use in this function) when building against >=dev-libs/libressl-3.3. Closes: https://bugs.gentoo.org/757123 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/php/php-7.4.13.ebuild')
-rw-r--r--dev-lang/php/php-7.4.13.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/php/php-7.4.13.ebuild b/dev-lang/php/php-7.4.13.ebuild
index 3ac0d8c9ace3..97ccf43d8c7c 100644
--- a/dev-lang/php/php-7.4.13.ebuild
+++ b/dev-lang/php/php-7.4.13.ebuild
@@ -150,7 +150,10 @@ BDEPEND="virtual/pkgconfig"
PHP_MV="$(ver_cut 1)"
-PATCHES=( "${FILESDIR}/php-iodbc-header-location.patch" )
+PATCHES=(
+ "${FILESDIR}"/php-iodbc-header-location.patch
+ "${FILESDIR}"/${P}-issue80368.patch
+)
php_install_ini() {
local phpsapi="${1}"