summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-09-19 22:32:16 -0400
committerBrian Evans <grknight@gentoo.org>2018-09-19 22:32:16 -0400
commita51890c8496984b6e774706bcdb05ff72bc8c4ce (patch)
tree43d194ba3948090f9bf36e1c35332780ca6aa005 /dev-lang/php
parentsys-kernel/gentoo-sources: Gentoo sources version bumps (diff)
downloadgentoo-a51890c8496984b6e774706bcdb05ff72bc8c4ce.tar.gz
gentoo-a51890c8496984b6e774706bcdb05ff72bc8c4ce.tar.bz2
gentoo-a51890c8496984b6e774706bcdb05ff72bc8c4ce.zip
dev-lang/php: Recent mysqlnd driver needs hash extension
Set REQUIRED_USE on mysql and mysqli to need hash as build failures occur without. Example: ext/mysqlnd/mysqlnd_auth.o: In function `php_mysqlnd_scramble_sha2': mysqlnd_auth.c:(.text+0x1054): undefined reference to `PHP_SHA256Init' Does not affect PHP 5.6 or 7.0 as they are security only Closes: https://bugs.gentoo.org/666598
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-7.1.22.ebuild3
-rw-r--r--dev-lang/php/php-7.2.10.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/php/php-7.1.22.ebuild b/dev-lang/php/php-7.1.22.ebuild
index 4d86e54abb4c..feba2bb1708a 100644
--- a/dev-lang/php/php-7.1.22.ebuild
+++ b/dev-lang/php/php-7.1.22.ebuild
@@ -142,7 +142,8 @@ REQUIRED_USE="
readline? ( !libedit )
recode? ( !imap !mysqli !mysql )
session-mm? ( session !threads )
- mysql? ( || ( mysqli pdo ) )
+ mysql? ( hash || ( mysqli pdo ) )
+ mysqli? ( hash )
"
PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
diff --git a/dev-lang/php/php-7.2.10.ebuild b/dev-lang/php/php-7.2.10.ebuild
index 4b8bb35fe160..8056b502a1f4 100644
--- a/dev-lang/php/php-7.2.10.ebuild
+++ b/dev-lang/php/php-7.2.10.ebuild
@@ -146,7 +146,8 @@ REQUIRED_USE="
readline? ( !libedit )
recode? ( !imap !mysqli !mysql )
session-mm? ( session !threads )
- mysql? ( || ( mysqli pdo ) )
+ mysql? ( hash || ( mysqli pdo ) )
+ mysqli? ( hash )
zip-encryption? ( zip )
"
PATCHES=(