summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-09 18:11:24 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-09 20:48:07 +0200
commit6cbb1015f80c550e41873048a7b5b660f98c4ea5 (patch)
tree48500b264c6436c3d6328ccf8584bf94a8887d4e /dev-lang/python-exec/python-exec-9999.ebuild
parentmedia-libs/glm: fix install phase (diff)
downloadgentoo-6cbb1015f80c550e41873048a7b5b660f98c4ea5.tar.gz
gentoo-6cbb1015f80c550e41873048a7b5b660f98c4ea5.tar.bz2
gentoo-6cbb1015f80c550e41873048a7b5b660f98c4ea5.zip
dev-lang/python-exec: Respect PYTHON_TARGETS (NFC)
Actually use PYTHON_TARGETS when building implementation list. This is NFC since all targets are package.use.forced but it lets advanced users customize behavior via un-forcing those flags. Bug: https://bugs.gentoo.org/693910 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python-exec/python-exec-9999.ebuild')
-rw-r--r--dev-lang/python-exec/python-exec-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/python-exec/python-exec-9999.ebuild b/dev-lang/python-exec/python-exec-9999.ebuild
index f5c7a17a180b..ca430aeaf2d8 100644
--- a/dev-lang/python-exec/python-exec-9999.ebuild
+++ b/dev-lang/python-exec/python-exec-9999.ebuild
@@ -33,8 +33,10 @@ src_prepare() {
src_configure() {
local pyimpls=() i EPYTHON
for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
+ if use "python_targets_${i}"; then
+ python_export "${i}" EPYTHON
+ pyimpls+=( "${EPYTHON}" )
+ fi
done
local myconf=(