summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-08 18:54:10 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-08 18:56:38 +0100
commitd6757565b9af0e8b663b64508c216c297417c405 (patch)
tree798b8b85f819d5dfbfb98c5ae9de31e2891946d3 /dev-lang/python-exec/python-exec-9999.ebuild
parentwww-client/google-chrome-beta: Bump (diff)
downloadgentoo-d6757565b9af0e8b663b64508c216c297417c405.tar.gz
gentoo-d6757565b9af0e8b663b64508c216c297417c405.tar.bz2
gentoo-d6757565b9af0e8b663b64508c216c297417c405.zip
dev-lang/python-exec: Wrappers were moved to /usr/bin (in git)
The both wrappers were moved to /usr/bin in order to make it possible to symlink them in place of /usr/bin/python{,2,3}. Compatibility symlinks are now installed in place of old locations.
Diffstat (limited to 'dev-lang/python-exec/python-exec-9999.ebuild')
-rw-r--r--dev-lang/python-exec/python-exec-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-lang/python-exec/python-exec-9999.ebuild b/dev-lang/python-exec/python-exec-9999.ebuild
index 98e011912663..8b64e11b3bcb 100644
--- a/dev-lang/python-exec/python-exec-9999.ebuild
+++ b/dev-lang/python-exec/python-exec-9999.ebuild
@@ -68,14 +68,14 @@ src_install() {
insinto /etc/python-exec
doins "${T}"/python-exec.conf
+ # Create compatibility symlinks
+ dosym ../../bin/python-exec2 /usr/lib/python-exec/python-exec2-c
+ dosym ../../bin/python-exec2.py /usr/lib/python-exec/python-exec2
+
+ # Create Python interpreter executable wrappers
local f
- for f in python{,2,3}; do
- # can't use symlinks here since random stuff
- # loves to do readlink on sys.executable...
- newbin python-exec2-c "${f}"
- done
- for f in python{,2,3}-config 2to3 idle pydoc pyvenv; do
- dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
+ for f in python{,2,3}{,-config} 2to3 idle pydoc pyvenv; do
+ dosym python-exec2 /usr/bin/"${f}"
done
}