summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-10 08:23:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-10 08:54:14 +0200
commit9caa139e7724f91d889f67434fad565e8807b086 (patch)
treef015cf00983dd4f946f2bf704b4b46553b4ed061 /dev-lang/python-exec
parentwww-servers/tomcat: bump to 9.0.64 (diff)
downloadgentoo-9caa139e7724f91d889f67434fad565e8807b086.tar.gz
gentoo-9caa139e7724f91d889f67434fad565e8807b086.tar.bz2
gentoo-9caa139e7724f91d889f67434fad565e8807b086.zip
dev-lang/python-exec: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/Manifest1
-rw-r--r--dev-lang/python-exec/python-exec-2.4.8.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-lang/python-exec/Manifest b/dev-lang/python-exec/Manifest
index 9e854122c4e7..676993dd9431 100644
--- a/dev-lang/python-exec/Manifest
+++ b/dev-lang/python-exec/Manifest
@@ -1,2 +1 @@
-DIST python-exec-2.4.8.tar.bz2 82671 BLAKE2B ac85f3dd6da3d1c535ad56a25edbbcb1d0e75b91e3567b80f27fd01d32a199a713909a8552dffaacbe96c43bca491f31c3f0c7f1a618fb9144814365686715cf SHA512 d6dabab217dc2f1817e2f4d159102a9467f51b26b91f4ae7fb7e4930d30334f74bd8a5f37cc60d58c6e1e61e89a3b4d2e1bd17413493ba86f38fa71250cf5ac1
DIST python-exec-2.4.9.tar.bz2 84300 BLAKE2B 77ad193f2602db392830eb4e2632562cfa1ca09bdc710e35dc141a036230ac21e63a51d297184740d85e6c3be8cb4b7ffefef270e51533ff15250f474437a52e SHA512 ad520dc7724bc71629e238226cd795214860e0a090a065dc85f782e6bd86c30ba46d58cb80d46221f4ff4a146332244b6670335a8f31f630088f477588ed8293
diff --git a/dev-lang/python-exec/python-exec-2.4.8.ebuild b/dev-lang/python-exec/python-exec-2.4.8.ebuild
deleted file mode 100644
index 4fd31fa50604..000000000000
--- a/dev-lang/python-exec/python-exec-2.4.8.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-inherit python-any-r1
-
-DESCRIPTION="Python script wrapper"
-HOMEPAGE="https://github.com/mgorny/python-exec/"
-SRC_URI="https://github.com/mgorny/python-exec/releases/download/v${PV}/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-# Internal Python project hack. Do not copy it. Ever.
-IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_} +native-symlinks test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lang/python-exec-conf
- !<=dev-lang/python-2.7.18-r3:2.7"
-BDEPEND="
- test? (
- $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
- )"
-
-python_check_deps() {
- has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local pyimpls=() i EPYTHON
- for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- _python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
- fi
- done
-
- local myconf=(
- --with-fallback-path="${EPREFIX}/usr/local/sbin:${EPREFIX}/usr/local/bin:${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin"
- --with-python-impls="${pyimpls[*]}"
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- if use native-symlinks; then
- local programs=( python python3 )
- local scripts=( python-config python3-config 2to3 idle pydoc pyvenv )
-
- local f
- for f in "${programs[@]}"; do
- # symlink the C wrapper for python to avoid shebang recursion
- # bug #568974
- dosym python-exec2c /usr/bin/"${f}"
- done
- for f in "${scripts[@]}"; do
- # those are python scripts (except for new python-configs)
- # so symlink them via the python wrapper
- dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
- done
- fi
-}