summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-11 11:07:33 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-11 11:07:46 -0500
commit56760ce3a29757b6cf00b585a9a1d480fdaf312f (patch)
tree8d443e066fc82cf2f309ffab0ef674554998fb3f /dev-lang/python/files
parentapp-admin/sysklogd: stable 1.5.1-r1 for hppa, bug #636046 (diff)
downloadgentoo-56760ce3a29757b6cf00b585a9a1d480fdaf312f.tar.gz
gentoo-56760ce3a29757b6cf00b585a9a1d480fdaf312f.tar.bz2
gentoo-56760ce3a29757b6cf00b585a9a1d480fdaf312f.zip
dev-lang/python: disable the nis module
This fails to build with glibc-2.26. Bug: https://bugs.gentoo.org/631488 Package-Manager: Portage-2.3.13_p1, Repoman-2.3.3_p81
Diffstat (limited to 'dev-lang/python/files')
-rw-r--r--dev-lang/python/files/2.7-disable-nis.patch21
-rw-r--r--dev-lang/python/files/3.6-disable-nis.patch21
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/python/files/2.7-disable-nis.patch b/dev-lang/python/files/2.7-disable-nis.patch
new file mode 100644
index 000000000000..5a6cb3e403f1
--- /dev/null
+++ b/dev-lang/python/files/2.7-disable-nis.patch
@@ -0,0 +1,21 @@
+--- a/setup.py
++++ b/setup.py
+@@ -1346,17 +1346,7 @@ class PyBuildExt(build_ext):
+ else:
+ missing.append('resource')
+
+- # Sun yellow pages. Some systems have the functions in libc.
+- if (host_platform not in ['cygwin', 'atheos', 'qnx6'] and
+- find_file('rpcsvc/yp_prot.h', inc_dirs, []) is not None):
+- if (self.compiler.find_library_file(lib_dirs, 'nsl')):
+- libs = ['nsl']
+- else:
+- libs = []
+- exts.append( Extension('nis', ['nismodule.c'],
+- libraries = libs) )
+- else:
+- missing.append('nis')
++ missing.append('nis')
+ else:
+ missing.extend(['nis', 'resource', 'termios'])
+
diff --git a/dev-lang/python/files/3.6-disable-nis.patch b/dev-lang/python/files/3.6-disable-nis.patch
new file mode 100644
index 000000000000..4e81847b5070
--- /dev/null
+++ b/dev-lang/python/files/3.6-disable-nis.patch
@@ -0,0 +1,21 @@
+--- a/setup.py
++++ b/setup.py
+@@ -1332,17 +1332,7 @@ class PyBuildExt(build_ext):
+ # Jeremy Hylton's rlimit interface
+ exts.append( Extension('resource', ['resource.c']) )
+
+- # Sun yellow pages. Some systems have the functions in libc.
+- if (host_platform not in ['cygwin', 'qnx6'] and
+- find_file('rpcsvc/yp_prot.h', inc_dirs, []) is not None):
+- if (self.compiler.find_library_file(lib_dirs, 'nsl')):
+- libs = ['nsl']
+- else:
+- libs = []
+- exts.append( Extension('nis', ['nismodule.c'],
+- libraries = libs) )
+- else:
+- missing.append('nis')
++ missing.append('nis')
+ else:
+ missing.extend(['nis', 'resource', 'termios'])
+