summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2017-08-16 10:41:01 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-29 22:18:13 +0200
commitf61d0e96e2de7346ec9de95a7876e1bb39582dc0 (patch)
treebbb9a2ed4de71ae3677bcf064ebba0fc5899e869 /dev-lang/python/files
parentdev-python/python-afl: remove unused patch. (diff)
downloadgentoo-f61d0e96e2de7346ec9de95a7876e1bb39582dc0.tar.gz
gentoo-f61d0e96e2de7346ec9de95a7876e1bb39582dc0.tar.bz2
gentoo-f61d0e96e2de7346ec9de95a7876e1bb39582dc0.zip
dev-lang/python: remove unused patches.
Diffstat (limited to 'dev-lang/python/files')
-rw-r--r--dev-lang/python/files/3.5-secondary-targets.patch19
-rw-r--r--dev-lang/python/files/3.5.1-cross-compile.patch75
-rw-r--r--dev-lang/python/files/python-3.4-gcc-5.patch37
3 files changed, 0 insertions, 131 deletions
diff --git a/dev-lang/python/files/3.5-secondary-targets.patch b/dev-lang/python/files/3.5-secondary-targets.patch
deleted file mode 100644
index eb3b0c71e7d5..000000000000
--- a/dev-lang/python/files/3.5-secondary-targets.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Mark all targets as "secondary"
-
-This allows make to avoid rebuilding unnecessary intermediate files, which
-is useful when cross-compiling.
-
-See Parser/pgen and Programs/_freeze_importlib in Makefile.pre.in.
-
-diff --git a/Makefile.pre.in b/Makefile.pre.in
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -1672,6 +1672,8 @@
- .PHONY: smelly funny patchcheck touch altmaninstall commoninstall
- .PHONY: gdbhooks
-
-+.SECONDARY:
-+
- # IF YOU PUT ANYTHING HERE IT WILL GO AWAY
- # Local Variables:
- # mode: makefile
diff --git a/dev-lang/python/files/3.5.1-cross-compile.patch b/dev-lang/python/files/3.5.1-cross-compile.patch
deleted file mode 100644
index 25a518bd1e65..000000000000
--- a/dev-lang/python/files/3.5.1-cross-compile.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-# HG changeset patch
-# User Martin Panter <vadmium+py@gmail.com>
-# Date 1461373124 0
-# Node ID 66e40df31faca467937c7b9d5d2e825471f97822
-# Parent a246047734b3496a7dc4ebaf1f0232dadf22eab6
-Issue #22359: Disable running cross-compiled _freeze_importlib and pgen
-
-Patch by Xavier de Gaye.
-
-diff --git a/Makefile.pre.in b/Makefile.pre.in
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -221,6 +221,7 @@ LIBOBJS= @LIBOBJS@
- PYTHON= python$(EXE)
- BUILDPYTHON= python$(BUILDEXE)
-
-+cross_compiling=@cross_compiling@
- PYTHON_FOR_BUILD=@PYTHON_FOR_BUILD@
- _PYTHON_HOST_PLATFORM=@_PYTHON_HOST_PLATFORM@
- BUILD_GNU_TYPE= @build@
-@@ -718,12 +719,16 @@ Programs/_freeze_importlib: Programs/_fr
- $(LINKCC) $(PY_LDFLAGS) -o $@ Programs/_freeze_importlib.o $(LIBRARY_OBJS_OMIT_FROZEN) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
-
- Python/importlib_external.h: $(srcdir)/Lib/importlib/_bootstrap_external.py Programs/_freeze_importlib
-- ./Programs/_freeze_importlib \
-- $(srcdir)/Lib/importlib/_bootstrap_external.py Python/importlib_external.h
-+ if test "$(cross_compiling)" != "yes"; then \
-+ ./Programs/_freeze_importlib \
-+ $(srcdir)/Lib/importlib/_bootstrap_external.py Python/importlib_external.h; \
-+ fi
-
- Python/importlib.h: $(srcdir)/Lib/importlib/_bootstrap.py Programs/_freeze_importlib
-- ./Programs/_freeze_importlib \
-- $(srcdir)/Lib/importlib/_bootstrap.py Python/importlib.h
-+ if test "$(cross_compiling)" != "yes"; then \
-+ ./Programs/_freeze_importlib \
-+ $(srcdir)/Lib/importlib/_bootstrap.py Python/importlib.h; \
-+ fi
-
-
- ############################################################################
-@@ -784,10 +789,18 @@ Python/sysmodule.o: $(srcdir)/Python/sys
- $(IO_OBJS): $(IO_H)
-
- $(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGEN)
-- @$(MKDIR_P) Include
-- $(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
-+ @$(MKDIR_P) Include
-+ if test "$(cross_compiling)" != "yes"; then \
-+ $(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C); \
-+ else \
-+ cp $(srcdir)/Include/graminit.h $(GRAMMAR_H); \
-+ fi
- $(GRAMMAR_C): $(GRAMMAR_H)
-- touch $(GRAMMAR_C)
-+ if test "$(cross_compiling)" != "yes"; then \
-+ touch $(GRAMMAR_C); \
-+ else \
-+ cp $(srcdir)/Python/graminit.c $(GRAMMAR_C); \
-+ fi
-
- $(PGEN): $(PGENOBJS)
- $(CC) $(OPT) $(PY_LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
-diff --git a/configure.ac b/configure.ac
---- a/configure.ac
-+++ b/configure.ac
-@@ -49,6 +49,7 @@ fi
- AC_CONFIG_SRCDIR([Include/object.h])
- AC_CONFIG_HEADER(pyconfig.h)
-
-+AC_SUBST(cross_compiling)
- AC_CANONICAL_HOST
- AC_SUBST(build)
- AC_SUBST(host)
-
diff --git a/dev-lang/python/files/python-3.4-gcc-5.patch b/dev-lang/python/files/python-3.4-gcc-5.patch
deleted file mode 100644
index 80afbd1c47bb..000000000000
--- a/dev-lang/python/files/python-3.4-gcc-5.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-changeset: 94583:689092296ad3
-branch: 3.4
-parent: 94579:645f3d750be1
-user: Victor Stinner <victor.stinner@gmail.com>
-date: Wed Feb 11 14:23:35 2015 +0100
-summary: Issue #23433: Fix faulthandler._stack_overflow()
-
-diff -r 645f3d750be1 -r 689092296ad3 Modules/faulthandler.c
---- a/Modules/faulthandler.c Tue Feb 10 14:49:32 2015 +0100
-+++ b/Modules/faulthandler.c Wed Feb 11 14:23:35 2015 +0100
-@@ -911,12 +911,12 @@
- }
-
- #if defined(HAVE_SIGALTSTACK) && defined(HAVE_SIGACTION)
--static void*
--stack_overflow(void *min_sp, void *max_sp, size_t *depth)
-+static Py_uintptr_t
-+stack_overflow(Py_uintptr_t min_sp, Py_uintptr_t max_sp, size_t *depth)
- {
- /* allocate 4096 bytes on the stack at each call */
- unsigned char buffer[4096];
-- void *sp = &buffer;
-+ Py_uintptr_t sp = (Py_uintptr_t)&buffer;
- *depth += 1;
- if (sp < min_sp || max_sp < sp)
- return sp;
-@@ -929,7 +929,8 @@
- faulthandler_stack_overflow(PyObject *self)
- {
- size_t depth, size;
-- char *sp = (char *)&depth, *stop;
-+ Py_uintptr_t sp = (Py_uintptr_t)&depth;
-+ Py_uintptr_t stop;
-
- depth = 0;
- stop = stack_overflow(sp - STACK_OVERFLOW_MAX_SIZE,
-