summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Jelten <jj@sft.lol>2022-11-22 20:11:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-23 07:53:42 +0100
commit3b7ae26f65794fed2d6b90b85d6a81a96b326702 (patch)
tree48904012f834888adf7d561827aa100fbcd65a67 /dev-lang/python/python-3.12.0_alpha2.ebuild
parentapp-arch/advancecomp: Bump to 2.4 (diff)
downloadgentoo-3b7ae26f65794fed2d6b90b85d6a81a96b326702.tar.gz
gentoo-3b7ae26f65794fed2d6b90b85d6a81a96b326702.tar.bz2
gentoo-3b7ae26f65794fed2d6b90b85d6a81a96b326702.zip
dev-lang/python: add valgrind support
When the valgrind useflag is enabled, Python performs a runtime check if it is run in the Valgrind VM, and adjusts its memory allocator to not use pymalloc. Valgrind then does a much better job in tracking the memory reachability. Closes: https://bugs.gentoo.org/610816 Signed-off-by: Jonas Jelten <jj@sft.lol> Closes: https://github.com/gentoo/gentoo/pull/11012 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python/python-3.12.0_alpha2.ebuild')
-rw-r--r--dev-lang/python/python-3.12.0_alpha2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.12.0_alpha2.ebuild b/dev-lang/python/python-3.12.0_alpha2.ebuild
index e10b1c493b27..9d0d10adab0b 100644
--- a/dev-lang/python/python-3.12.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha2.ebuild
@@ -31,7 +31,7 @@ SLOT="${PYVER}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="
bluetooth build +ensurepip examples gdbm hardened libedit lto
- +ncurses pgo +readline +sqlite +ssl test tk
+ +ncurses pgo +readline +sqlite +ssl test tk valgrind
"
RESTRICT="!test? ( test )"
@@ -72,6 +72,7 @@ DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
test? ( app-arch/xz-utils[extra-filters(+)] )
+ valgrind? ( dev-util/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
@@ -207,6 +208,7 @@ src_configure() {
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
+ $(use_with valgrind)
)
# disable implicit optimization/debugging flags