summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-14 17:00:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-14 17:29:05 +0100
commitcba81ae61e4fb5b260f91a540a1988e9091768f2 (patch)
treebafe67d0492438e884f2eba4306b7ab809a1cb7c /dev-lang/python/python-3.8.12_p1.ebuild
parentdev-perl/Module-Info: EAPI=8 bump (diff)
downloadgentoo-cba81ae61e4fb5b260f91a540a1988e9091768f2.tar.gz
gentoo-cba81ae61e4fb5b260f91a540a1988e9091768f2.tar.bz2
gentoo-cba81ae61e4fb5b260f91a540a1988e9091768f2.zip
dev-lang/python: Force stdlib distutils for build
Closes: https://bugs.gentoo.org/823728 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python/python-3.8.12_p1.ebuild')
-rw-r--r--dev-lang/python/python-3.8.12_p1.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.8.12_p1.ebuild b/dev-lang/python/python-3.8.12_p1.ebuild
index a95b30f11b9d..ff54e4402ebc 100644
--- a/dev-lang/python/python-3.8.12_p1.ebuild
+++ b/dev-lang/python/python-3.8.12_p1.ebuild
@@ -179,6 +179,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=