summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-16 22:24:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-16 22:27:50 +0100
commit6e8f25e1d1b435e6b28053108a6bd9617a5451cd (patch)
tree09ae6e3b7d3e026009089503b61cf389c3ed6c32 /dev-lang/python
parentdev-libs/tree-sitter: Drop old (diff)
downloadgentoo-6e8f25e1d1b435e6b28053108a6bd9617a5451cd.tar.gz
gentoo-6e8f25e1d1b435e6b28053108a6bd9617a5451cd.tar.bz2
gentoo-6e8f25e1d1b435e6b28053108a6bd9617a5451cd.zip
dev-lang/python: Enable sqlite by default
SQLite3 is a common dependency of many programs written in Python. Enable it by default to improve the standard user experience. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.7.18_p7.ebuild2
-rw-r--r--dev-lang/python/python-3.10.0_alpha6-r2.ebuild2
-rw-r--r--dev-lang/python/python-3.6.13.ebuild2
-rw-r--r--dev-lang/python/python-3.7.10.ebuild2
-rw-r--r--dev-lang/python/python-3.8.8.ebuild2
-rw-r--r--dev-lang/python/python-3.9.2.ebuild2
6 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/python/python-2.7.18_p7.ebuild b/dev-lang/python/python-2.7.18_p7.ebuild
index 1f7f426a4b16..527113ad67ca 100644
--- a/dev-lang/python/python-2.7.18_p7.ebuild
+++ b/dev-lang/python/python-2.7.18_p7.ebuild
@@ -23,7 +23,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sparc x86"
-IUSE="-berkdb bluetooth build elibc_uclibc examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
+IUSE="-berkdb bluetooth build elibc_uclibc examples gdbm hardened ipv6 libressl +ncurses +readline +sqlite +ssl +threads tk +wide-unicode wininst +xml"
# Do not add a dependency on dev-lang/python to this ebuild.
# If you need to apply a patch which requires python for bootstrapping, please
diff --git a/dev-lang/python/python-3.10.0_alpha6-r2.ebuild b/dev-lang/python/python-3.10.0_alpha6-r2.ebuild
index adedfd6f3388..7d2e54b48f91 100644
--- a/dev-lang/python/python-3.10.0_alpha6-r2.ebuild
+++ b/dev-lang/python/python-3.10.0_alpha6-r2.ebuild
@@ -24,7 +24,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tk wininst +xml"
+IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline +sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
# Do not add a dependency on dev-lang/python to this ebuild.
diff --git a/dev-lang/python/python-3.6.13.ebuild b/dev-lang/python/python-3.6.13.ebuild
index 571d4f1ad6ed..9895dab7479a 100644
--- a/dev-lang/python/python-3.6.13.ebuild
+++ b/dev-lang/python/python-3.6.13.ebuild
@@ -23,7 +23,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}/${PYVER}m"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sparc x86"
-IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test +threads tk wininst +xml"
+IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline +sqlite +ssl test +threads tk wininst +xml"
RESTRICT="!test? ( test )"
# Do not add a dependency on dev-lang/python to this ebuild.
diff --git a/dev-lang/python/python-3.7.10.ebuild b/dev-lang/python/python-3.7.10.ebuild
index 3096dbae0b40..b0f877ad04f8 100644
--- a/dev-lang/python/python-3.7.10.ebuild
+++ b/dev-lang/python/python-3.7.10.ebuild
@@ -23,7 +23,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}/${PYVER}m"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tk wininst +xml"
+IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline +sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
# Do not add a dependency on dev-lang/python to this ebuild.
diff --git a/dev-lang/python/python-3.8.8.ebuild b/dev-lang/python/python-3.8.8.ebuild
index d22161e4b805..4806f5ff97e2 100644
--- a/dev-lang/python/python-3.8.8.ebuild
+++ b/dev-lang/python/python-3.8.8.ebuild
@@ -24,7 +24,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tk wininst +xml"
+IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline +sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
# Do not add a dependency on dev-lang/python to this ebuild.
diff --git a/dev-lang/python/python-3.9.2.ebuild b/dev-lang/python/python-3.9.2.ebuild
index 6c06b799495c..defe44939ba6 100644
--- a/dev-lang/python/python-3.9.2.ebuild
+++ b/dev-lang/python/python-3.9.2.ebuild
@@ -24,7 +24,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tk wininst +xml"
+IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline +sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
# Do not add a dependency on dev-lang/python to this ebuild.