summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-03 20:41:29 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-03 20:42:16 -0400
commitb8cb87b5af9ab23e60864a4c66988c0f595f5b77 (patch)
tree2a5ad5adc7aeef49ab7be5b06a77c663b4ac0e49 /dev-lang/python
parentnet-misc/openssh: fix USE=kerberos build #590382 (diff)
downloadgentoo-b8cb87b5af9ab23e60864a4c66988c0f595f5b77.tar.gz
gentoo-b8cb87b5af9ab23e60864a4c66988c0f595f5b77.tar.bz2
gentoo-b8cb87b5af9ab23e60864a4c66988c0f595f5b77.zip
dev-lang/python: disable MPROTECT
The hardened team can figure this shit out. Package-Manager: portage-2.3.0_p16
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.7.12.ebuild7
-rw-r--r--dev-lang/python/python-3.4.5.ebuild7
-rw-r--r--dev-lang/python/python-3.5.2.ebuild7
3 files changed, 3 insertions, 18 deletions
diff --git a/dev-lang/python/python-2.7.12.ebuild b/dev-lang/python/python-2.7.12.ebuild
index 992882b2ebd3..2901f8f0870e 100644
--- a/dev-lang/python/python-2.7.12.ebuild
+++ b/dev-lang/python/python-2.7.12.ebuild
@@ -216,12 +216,7 @@ src_compile() {
cd "${BUILD_DIR}" || die
emake
- # Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
- pax-mark E python
- else
- pax-mark m python
- fi
+ pax-mark m python
}
src_test() {
diff --git a/dev-lang/python/python-3.4.5.ebuild b/dev-lang/python/python-3.4.5.ebuild
index 433a3a373da8..88f5362878bc 100644
--- a/dev-lang/python/python-3.4.5.ebuild
+++ b/dev-lang/python/python-3.4.5.ebuild
@@ -175,12 +175,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
- # Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
- pax-mark E python
- else
- pax-mark m python
- fi
+ pax-mark m python
}
src_test() {
diff --git a/dev-lang/python/python-3.5.2.ebuild b/dev-lang/python/python-3.5.2.ebuild
index ea66658420d0..a1f4150b9b91 100644
--- a/dev-lang/python/python-3.5.2.ebuild
+++ b/dev-lang/python/python-3.5.2.ebuild
@@ -174,12 +174,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
- # Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
- pax-mark E python
- else
- pax-mark m python
- fi
+ pax-mark m python
}
src_test() {