summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-10-16 17:57:00 +0200
committerFabian Groffen <grobian@gentoo.org>2021-10-16 17:57:14 +0200
commite56274ae84c1aa457d87d86605ab3ec05cfc7638 (patch)
tree3928a4568a8620194b2eea5d745f9b0ab75a1a9f /dev-lang/ruby/files/2.7/900-musl-coroutine.patch
parentapp-antivirus/clamav: fixed mode on .initd files (diff)
downloadgentoo-e56274ae84c1aa457d87d86605ab3ec05cfc7638.tar.gz
gentoo-e56274ae84c1aa457d87d86605ab3ec05cfc7638.tar.bz2
gentoo-e56274ae84c1aa457d87d86605ab3ec05cfc7638.zip
dev-lang/ruby: add patches for musl
Fix two problems: 1. fix compilation problem in coroutine 2. address stack size such that one can e.g. run puppet Closes: https://bugs.gentoo.org/721068 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-lang/ruby/files/2.7/900-musl-coroutine.patch')
-rw-r--r--dev-lang/ruby/files/2.7/900-musl-coroutine.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-lang/ruby/files/2.7/900-musl-coroutine.patch b/dev-lang/ruby/files/2.7/900-musl-coroutine.patch
new file mode 100644
index 000000000000..ed47c54e29c7
--- /dev/null
+++ b/dev-lang/ruby/files/2.7/900-musl-coroutine.patch
@@ -0,0 +1,41 @@
+Adapted for Gentoo version 2.7.4
+
+From b570e7de87aaad8c903176d835e8124127f627b3 Mon Sep 17 00:00:00 2001
+From: Andrew Aladjev <aladjev.andrew@gmail.com>
+Date: Sat, 26 Sep 2020 12:58:06 +0300
+Subject: [PATCH] fixed default coroutine selection for musl
+
+---
+ configure.ac | 5 ++++-
+ coroutine/copy/Context.c | 2 ++
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index ab5d532c103b..084f0936c006 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2364,7 +2364,10 @@
+ rb_cv_coroutine=copy
+ ],
+ [*], [
+- rb_cv_coroutine=ucontext
++ AC_CHECK_FUNCS([getcontext swapcontext makecontext],
++ [rb_cv_coroutine=ucontext],
++ [rb_cv_coroutine=copy; break]
++ )
+ ]
+ )
+ AC_MSG_RESULT(${rb_cv_coroutine})
+diff --git a/coroutine/copy/Context.c b/coroutine/copy/Context.c
+index c1b4144e9857..94a7f57f7d89 100644
+--- a/coroutine/copy/Context.c
++++ b/coroutine/copy/Context.c
+@@ -5,6 +5,8 @@
+ * Copyright, 2019, by Samuel Williams.
+ */
+
++#include <sys/types.h>
++
+ #include "Context.h"
+
+ // http://gcc.gnu.org/onlinedocs/gcc/Alternate-Keywords.html