summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-02-03 14:06:35 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-02-05 11:30:15 -0800
commit5c10219a508f89e245ad8f25d1e04e262a34cd8c (patch)
tree644e95f10ae66d2e608d541d77771e56cc564d9a /dev-lang/rust
parentmail-client/neomutt: Version bump to 2021-02-05 (diff)
downloadgentoo-5c10219a508f89e245ad8f25d1e04e262a34cd8c.tar.gz
gentoo-5c10219a508f89e245ad8f25d1e04e262a34cd8c.tar.bz2
gentoo-5c10219a508f89e245ad8f25d1e04e262a34cd8c.zip
dev-lang/rust: add rustc -vV patch to 1.49.0
No revbump, since moz ebuilds have workaround now and we can't patch rust-bin. Bug: https://bugs.gentoo.org/768543 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/files/1.49.0-llvm-ver-display.patch31
-rw-r--r--dev-lang/rust/rust-1.49.0.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-lang/rust/files/1.49.0-llvm-ver-display.patch b/dev-lang/rust/files/1.49.0-llvm-ver-display.patch
new file mode 100644
index 000000000000..e2b6396b5eb8
--- /dev/null
+++ b/dev-lang/rust/files/1.49.0-llvm-ver-display.patch
@@ -0,0 +1,31 @@
+From 64c1b0d614949f405d8b4498a3b2ea59d9ec230e Mon Sep 17 00:00:00 2001
+From: bjorn3 <bjorn3@users.noreply.github.com>
+Date: Wed, 13 Jan 2021 12:15:42 +0100
+Subject: [PATCH] Fix -Cpasses=list and llvm version print with -vV
+
+---
+ compiler/rustc_driver/src/lib.rs | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/compiler/rustc_driver/src/lib.rs b/compiler/rustc_driver/src/lib.rs
+index f434673c39e10..c668c94bb08c4 100644
+--- a/compiler/rustc_driver/src/lib.rs
++++ b/compiler/rustc_driver/src/lib.rs
+@@ -808,7 +808,7 @@ pub fn version(binary: &str, matches: &getopts::Matches) {
+ println!("commit-date: {}", unw(util::commit_date_str()));
+ println!("host: {}", config::host_triple());
+ println!("release: {}", unw(util::release_str()));
+- if cfg!(llvm) {
++ if cfg!(feature = "llvm") {
+ get_builtin_codegen_backend("llvm")().print_version();
+ }
+ }
+@@ -1096,7 +1096,7 @@ pub fn handle_options(args: &[String]) -> Option<getopts::Matches> {
+ }
+
+ if cg_flags.iter().any(|x| *x == "passes=list") {
+- if cfg!(llvm) {
++ if cfg!(feature = "llvm") {
+ get_builtin_codegen_backend("llvm")().print_passes();
+ }
+ return None;
diff --git a/dev-lang/rust/rust-1.49.0.ebuild b/dev-lang/rust/rust-1.49.0.ebuild
index 776c4276d3a8..1ff75dfdbed3 100644
--- a/dev-lang/rust/rust-1.49.0.ebuild
+++ b/dev-lang/rust/rust-1.49.0.ebuild
@@ -136,6 +136,7 @@ PATCHES=(
"${FILESDIR}"/1.47.0-ignore-broken-and-non-applicable-tests.patch
"${FILESDIR}"/1.47.0-llvm-tensorflow-fix.patch
"${FILESDIR}"/1.49.0-gentoo-musl-target-specs.patch
+ "${FILESDIR}"/1.49.0-llvm-ver-display.patch
)
S="${WORKDIR}/${MY_P}-src"