summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-12-21 20:21:35 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-12-21 20:22:26 +0800
commit6a7ff6155c5dce32c19e448e2e473b0f0d791f64 (patch)
tree8964b381a08bb229f4df1ce46325295551a9f5e8 /dev-lang/rust
parentnet-libs/axtls-2.1.5-r100: fix accidental whitespace mangling (diff)
downloadgentoo-6a7ff6155c5dce32c19e448e2e473b0f0d791f64.tar.gz
gentoo-6a7ff6155c5dce32c19e448e2e473b0f0d791f64.tar.bz2
gentoo-6a7ff6155c5dce32c19e448e2e473b0f0d791f64.zip
dev-lang/rust: use ED in removal operations.
This does not affect non-prefix systems and the prefix systems fail to install before this commit. Therefore, no revision is is required. Bug: https://bugs.gentoo.org/689562 Bug: https://bugs.gentoo.org/689160 Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.48.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/rust/rust-1.48.0.ebuild b/dev-lang/rust/rust-1.48.0.ebuild
index 19da77c7c399..779372ba4e66 100644
--- a/dev-lang/rust/rust-1.48.0.ebuild
+++ b/dev-lang/rust/rust-1.48.0.ebuild
@@ -510,8 +510,8 @@ src_install() {
)
# bug #689562, #689160
- rm -v "${D}/usr/lib/${PN}/${PV}/etc/bash_completion.d/cargo" || die
- rmdir -v "${D}/usr/lib/${PN}/${PV}"/etc{/bash_completion.d,} || die
+ rm -v "${ED}/usr/lib/${PN}/${PV}/etc/bash_completion.d/cargo" || die
+ rmdir -v "${ED}/usr/lib/${PN}/${PV}"/etc{/bash_completion.d,} || die
dobashcomp build/tmp/dist/cargo-image/etc/bash_completion.d/cargo
local symlinks=(