summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-02 14:02:31 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-02 14:03:21 -0700
commit90086b35b98db16492aff36bae392ffafc64f66b (patch)
treeaa0bc0ffc1c1c14a272c31f39bac213f31361d43 /dev-lang/rust
parentdev-lang/rust-bin: add QA_EXECSTACK for rmeta sections (diff)
downloadgentoo-90086b35b98db16492aff36bae392ffafc64f66b.tar.gz
gentoo-90086b35b98db16492aff36bae392ffafc64f66b.tar.bz2
gentoo-90086b35b98db16492aff36bae392ffafc64f66b.zip
dev-lang/rust: adjust QA_EXECSTACK variable again
Bug: https://bugs.gentoo.org/806466 Closes: https://bugs.gentoo.org/819402 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.52.1.ebuild3
-rw-r--r--dev-lang/rust/rust-1.53.0.ebuild3
-rw-r--r--dev-lang/rust/rust-1.54.0.ebuild3
-rw-r--r--dev-lang/rust/rust-1.55.0.ebuild3
-rw-r--r--dev-lang/rust/rust-1.56.0-r1.ebuild3
-rw-r--r--dev-lang/rust/rust-1.56.1.ebuild3
6 files changed, 6 insertions, 12 deletions
diff --git a/dev-lang/rust/rust-1.52.1.ebuild b/dev-lang/rust/rust-1.52.1.ebuild
index 30db42404e6a..9957b7ceb23d 100644
--- a/dev-lang/rust/rust-1.52.1.ebuild
+++ b/dev-lang/rust/rust-1.52.1.ebuild
@@ -141,8 +141,7 @@ QA_SONAME="
# An rmeta file is custom binary format that contains the metadata for the crate.
# rmeta files do not support linking, since they do not contain compiled object files.
# so we can safely silence the warning for this QA check.
-QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
-QA_EXECSTACK="${QA_WX_LOAD}"
+QA_EXECSTACK="usr/lib/${PN}/${PV}/lib/rustlib/*/lib*.rlib:lib.rmeta"
# causes double bootstrap
RESTRICT="test"
diff --git a/dev-lang/rust/rust-1.53.0.ebuild b/dev-lang/rust/rust-1.53.0.ebuild
index aeb7bd1f11c8..fa79d5221f5f 100644
--- a/dev-lang/rust/rust-1.53.0.ebuild
+++ b/dev-lang/rust/rust-1.53.0.ebuild
@@ -143,8 +143,7 @@ QA_SONAME="
# An rmeta file is custom binary format that contains the metadata for the crate.
# rmeta files do not support linking, since they do not contain compiled object files.
# so we can safely silence the warning for this QA check.
-QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
-QA_EXECSTACK="${QA_WX_LOAD}"
+QA_EXECSTACK="usr/lib/${PN}/${PV}/lib/rustlib/*/lib*.rlib:lib.rmeta"
# causes double bootstrap
RESTRICT="test"
diff --git a/dev-lang/rust/rust-1.54.0.ebuild b/dev-lang/rust/rust-1.54.0.ebuild
index 0b2c51587d67..0d1daa9be3c5 100644
--- a/dev-lang/rust/rust-1.54.0.ebuild
+++ b/dev-lang/rust/rust-1.54.0.ebuild
@@ -143,8 +143,7 @@ QA_SONAME="
# An rmeta file is custom binary format that contains the metadata for the crate.
# rmeta files do not support linking, since they do not contain compiled object files.
# so we can safely silence the warning for this QA check.
-QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
-QA_EXECSTACK="${QA_WX_LOAD}"
+QA_EXECSTACK="usr/lib/${PN}/${PV}/lib/rustlib/*/lib*.rlib:lib.rmeta"
# causes double bootstrap
RESTRICT="test"
diff --git a/dev-lang/rust/rust-1.55.0.ebuild b/dev-lang/rust/rust-1.55.0.ebuild
index 366d1e5149b8..99d6951548d7 100644
--- a/dev-lang/rust/rust-1.55.0.ebuild
+++ b/dev-lang/rust/rust-1.55.0.ebuild
@@ -143,8 +143,7 @@ QA_SONAME="
# An rmeta file is custom binary format that contains the metadata for the crate.
# rmeta files do not support linking, since they do not contain compiled object files.
# so we can safely silence the warning for this QA check.
-QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
-QA_EXECSTACK="${QA_WX_LOAD}"
+QA_EXECSTACK="usr/lib/${PN}/${PV}/lib/rustlib/*/lib*.rlib:lib.rmeta"
# causes double bootstrap
RESTRICT="test"
diff --git a/dev-lang/rust/rust-1.56.0-r1.ebuild b/dev-lang/rust/rust-1.56.0-r1.ebuild
index a388d0a00694..b12ed45601fe 100644
--- a/dev-lang/rust/rust-1.56.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.56.0-r1.ebuild
@@ -143,8 +143,7 @@ QA_SONAME="
# An rmeta file is custom binary format that contains the metadata for the crate.
# rmeta files do not support linking, since they do not contain compiled object files.
# so we can safely silence the warning for this QA check.
-QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
-QA_EXECSTACK="${QA_WX_LOAD}"
+QA_EXECSTACK="usr/lib/${PN}/${PV}/lib/rustlib/*/lib*.rlib:lib.rmeta"
# causes double bootstrap
RESTRICT="test"
diff --git a/dev-lang/rust/rust-1.56.1.ebuild b/dev-lang/rust/rust-1.56.1.ebuild
index 59c50dac02da..690bbad18071 100644
--- a/dev-lang/rust/rust-1.56.1.ebuild
+++ b/dev-lang/rust/rust-1.56.1.ebuild
@@ -143,8 +143,7 @@ QA_SONAME="
# An rmeta file is custom binary format that contains the metadata for the crate.
# rmeta files do not support linking, since they do not contain compiled object files.
# so we can safely silence the warning for this QA check.
-QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*rmeta"
-QA_EXECSTACK="${QA_WX_LOAD}"
+QA_EXECSTACK="usr/lib/${PN}/${PV}/lib/rustlib/*/lib*.rlib:lib.rmeta"
# causes double bootstrap
RESTRICT="test"